Bug 1128760 - IIO Accelerometer regression on ThinkPad twist
Summary: IIO Accelerometer regression on ThinkPad twist
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 13:47 UTC by Elad Alfassa
Modified: 2015-10-21 08:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-21 08:49:41 UTC


Attachments (Terms of Use)

Description Elad Alfassa 2014-08-11 13:47:43 UTC
Hi.

Using kernel 3.15.8-200.fc20.x86_64, the accelerometer works as intended with the Thinkpad Twist.

However, using rawhide kernel 3.16.0-1.fc22.x86_64, I get Resource temporarily unavailable when trying to read from the accelerometer.

I tried to report this in the upstream kernel bugzilla, but I couldn't find the right component, so I filed it here. If you know what is the right component in the upstream bugzilla, let me know.

Comment 1 Bastien Nocera 2014-08-12 19:52:51 UTC
This is using:
https://github.com/hadess/iio-sensor-proxy
to read from the IIO sensor.

Those are the errors:
https://github.com/hadess/iio-sensor-proxy/issues/1#issue-39769514

Comment 2 Jaroslav Reznik 2015-03-03 16:11:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 Justin M. Forbes 2015-10-20 19:42:08 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.

Comment 4 Bastien Nocera 2015-10-21 08:29:18 UTC
Elad, best send this to the IIO mailing-list if it still happens.

Comment 5 Elad Alfassa 2015-10-21 08:49:41 UTC
No, it has been fixed upstream long ago.


Note You need to log in before you can comment on or make changes to this bug.