Bug 1128769 - rhel-osp hosts memory display is wrong
Summary: rhel-osp hosts memory display is wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z1
: Installer
Assignee: Scott Seago
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 14:11 UTC by Ofer Blaut
Modified: 2014-10-01 13:26 UTC (History)
7 users (show)

Fixed In Version: rhel-osp-installer-0.3.4-2.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, a calculation error incorrectly displayed the total count of a host's memory in Red Hat Enterprise Linux OpenStack Platform installer. This update corrects the calculation, and the memory total is now displayed correctly.
Clone Of:
Environment:
Last Closed: 2014-10-01 13:26:26 UTC


Attachments (Terms of Use)
Host memeory (75.80 KB, application/octet-stream)
2014-08-11 14:11 UTC, Ofer Blaut
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Ofer Blaut 2014-08-11 14:11:35 UTC
Created attachment 925773 [details]
Host memeory

Description of problem:


Under deployment -> hosts-> Assigned -> Memory

The memory should be 32G but it 0.032G 

See attached picture

  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Mike Burns 2014-08-11 17:04:41 UTC
looks like we're dividing by 1024 an extra time.  We're reporting in TB, not GB

Comment 4 Jason E. Rist 2014-08-11 19:08:50 UTC
https://github.com/theforeman/staypuft/pull/264
Has been merged

Comment 8 Ofer Blaut 2014-09-21 08:53:46 UTC
verified 

rhel-osp-installer-0.3.5-1.el6ost.noarch

Comment 10 errata-xmlrpc 2014-10-01 13:26:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.