Bug 1128777 - packstack all in one install fails at Ceilometer install:"Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list mongodb-server' returned 1: Error: No matching Packages to list"
Summary: packstack all in one install fails at Ceilometer install:"Error: Execution of...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: distribution
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: Havana
Assignee: Perry Myers
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 14:22 UTC by Manoj Neelapareddy
Modified: 2015-03-17 20:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-17 20:56:42 UTC


Attachments (Terms of Use)

Description Manoj Neelapareddy 2014-08-11 14:22:57 UTC
Description of problem:
Havana packstack all in one install fails at Ceilometer install with error "Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list mongodb-server' returned 1: Error: No matching Packages to list"


Version-Release number of selected component (if applicable):
CentOS6.5/Havana

How reproducible: Always

Steps to Reproduce:

On CentOS6.5, do following:

yum install -y http://rdo.fedorapeople.org/openstack-havana/rdo-release-havana.rpm 
yum install -y http://epel.mirror.net.in/epel/6/i386/epel-release-6-8.noarch.rpm
yum install -y openstack-packstack
packstack --gen-answer-file=/root/answers.txt
packstack --answer-file=/root/answers.txt

Now packstack install would fail with error:

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list mongodb-server' returned 1: Error: No matching Packages to list

Now please see bug#1128488 which says that mongodb-server is removed from EPEL6 repo.

But, packstack/ceilometer expects that mongodb-server exists in EPEL6 repo.

Actual results:

packstack all in one setup fails as it can't find mongodb-server in EPEL6

Expected results:

packstack all in one install is successfull.


Additional info:

Please see bug#1128488

Comment 1 Manoj Neelapareddy 2014-08-11 14:29:51 UTC
This would need the fix as well:

http://openstack.redhat.com/CeilometerQuickStart

This link refers to do "sudo yum install -y mongodb-server mongodb".
So, this would need a correction as well.

Comment 4 Manoj Neelapareddy 2014-08-13 07:08:41 UTC
Here is the version of packstack I am using:

[root@server-ext-2a ~]# rpm -qa | grep packstack
openstack-packstack-puppet-2013.2.1-0.36.dev1013.el6.noarch
openstack-packstack-2013.2.1-0.36.dev1013.el6.noarch
[root@server-ext-2a ~]# 

here is how I installed it:

yum install -y http://rdo.fedorapeople.org/openstack-havana/rdo-release-havana.rpm 
yum install -y http://epel.mirror.net.in/epel/6/i386/epel-release-6-8.noarch.rpm
yum install -y openstack-packstack

Comment 5 Martin Magr 2014-08-14 13:29:01 UTC
So either we should get MongoDB packages to RDO repos or we should change Packstack (rdo-release) to use community repo [1] and packages instead. If we decide to use community repo, we will need to update puppetlabs-mongodb in OPM, because current version won't work with newer package naming convention.

[1] http://docs.mongodb.org/manual/tutorial/install-mongodb-on-red-hat-centos-or-fedora-linux/

Comment 6 Lars Kellogg-Stedman 2015-03-17 20:56:42 UTC
mongodb-server is now available in EPEL6 (https://apps.fedoraproject.org/packages/mongodb shows version 2.4.12-3.el6).


Note You need to log in before you can comment on or make changes to this bug.