Bug 1128848 - [abrt] evolution-2.32.3-33.el6: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-2.32.3-33.el6: Process /usr/bin/evolution was killed by sign...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glib2
Version: 6.6
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: Desktop QE
URL:
Whiteboard: abrt_hash:e24c4247a5c7ce2bb5d65442c4c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 15:56 UTC by Jiri Koten
Modified: 2014-10-14 07:29 UTC (History)
6 users (show)

Fixed In Version: glib2-2.28.8-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:29:02 UTC


Attachments (Terms of Use)
File: dso_list (25.28 KB, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details
File: last_occurrence (10 bytes, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details
File: cgroup (97 bytes, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details
File: var_log_messages (319 bytes, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details
File: maps (97.45 KB, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details
File: backtrace (51.75 KB, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details
File: xsession_errors (98.88 KB, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details
File: limits (1.29 KB, text/plain)
2014-08-11 15:56 UTC, Jiri Koten
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1538 normal SHIPPED_LIVE glib2 bug fix and enhancement update 2014-10-14 01:21:43 UTC

Description Jiri Koten 2014-08-11 15:56:33 UTC
Version-Release number of selected component:
evolution-2.32.3-33.el6

Additional info:
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        evolution
crash_function: emit_signal_instance_in_idle_cb
kernel:         2.6.32-495.el6.x86_64

truncated backtrace:
:Thread no. 1 (2 frames)
: #5 emit_signal_instance_in_idle_cb at gdbusconnection.c
: #10 IA__gtk_main at gtkmain.c

Comment 1 Jiri Koten 2014-08-11 15:56:36 UTC
Created attachment 925828 [details]
File: dso_list

Comment 2 Jiri Koten 2014-08-11 15:56:37 UTC
Created attachment 925829 [details]
File: last_occurrence

Comment 3 Jiri Koten 2014-08-11 15:56:38 UTC
Created attachment 925830 [details]
File: cgroup

Comment 4 Jiri Koten 2014-08-11 15:56:39 UTC
Created attachment 925831 [details]
File: var_log_messages

Comment 5 Jiri Koten 2014-08-11 15:56:43 UTC
Created attachment 925832 [details]
File: maps

Comment 6 Jiri Koten 2014-08-11 15:56:45 UTC
Created attachment 925833 [details]
File: backtrace

Comment 7 Jiri Koten 2014-08-11 15:56:49 UTC
Created attachment 925834 [details]
File: xsession_errors

Comment 8 Jiri Koten 2014-08-11 15:56:51 UTC
Created attachment 925835 [details]
File: limits

Comment 11 Matthew Barnes 2014-08-21 23:30:39 UTC
Stack trace looks a little different, but I think this might be another dupe of bug 1126916.  I'll just reassign it for now so as not to be too hasty.

Something is apparently very wrong with GObject's type registration in RHEL 6.

Comment 12 Matthias Clasen 2014-08-26 19:19:48 UTC
I don't see the commonality - the stacktrace here looks entirely different from the one in 1126916.

Comment 13 Matthias Clasen 2014-09-04 17:53:09 UTC
Ray found this very relevant looking fix that went into glib 2.29 (ie newer than our backport):

Bug 651133 - race condition in GDBusConnection's emit_signal_instance_in_idle_cb (edit)

Comment 14 Matthias Clasen 2014-09-04 18:21:14 UTC
setting devack+ since we have a pretty likely fix

Comment 15 Colin Walters 2014-09-08 19:31:56 UTC
The correct link looks like: https://bugzilla.gnome.org/show_bug.cgi?id=651133

So looking at that bug, there were several followup fixes.  Matthew, are you going to try backporting them?

How reproducible is this crash?

Comment 16 Matthew Barnes 2014-09-09 18:02:47 UTC
(In reply to Colin Walters from comment #15)
> So looking at that bug, there were several followup fixes.  Matthew, are you
> going to try backporting them?

Yeah, taking a crack at it now.

Comment 17 Colin Walters 2014-09-09 19:49:24 UTC
I'm OK with the updated patches here: http://pkgs.devel.redhat.com/cgit/rpms/glib2/commit/?h=rhel-6.6&id=59e30689e73af14ccbf33caa33e090b9dbe2d07e

The patches are nontrivial, but they're backports of commits that have existed upstream for some time.  An additional mitigating factor is that the patches only affect the GDBus code, which is new with this rebase, and thus nothing else can be using it (yet).

Comment 19 errata-xmlrpc 2014-10-14 07:29:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1538.html


Note You need to log in before you can comment on or make changes to this bug.