Bug 1128876 - FSW 6.1 Admin Guide must be expanded to cover SwitchYard features (in FSW/Karaf console)
Summary: FSW 6.1 Admin Guide must be expanded to cover SwitchYard features (in FSW/Kar...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Documentation
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: soa-docs@redhat.com
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 17:29 UTC by Len DiMaggio
Modified: 2014-08-11 23:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 23:57:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Len DiMaggio 2014-08-11 17:29:25 UTC
Description of problem:

    FSW 6.1 Admin Guide - should also cover these commands in the Fuse console

        switchyard:component-list         List switchyard components.
        switchyard:deployment-list        List switchyard deployments.
        switchyard:gateway                Perform an operation on a gateway.
        switchyard:get-version            Returns the version installed on the system.
        switchyard:list-applications      Returns a list of all SwitchYard applications deployed on the system.
        switchyard:list-references        Returns a list of SwitchYard references used by application(s) deployed on the system.
        switchyard:list-services          Returns a list of SwitchYard services used by application(s) deployed on the system.
        switchyard:namespace-list         List switchyard namespaces.
        switchyard:read-application       Returns a details about a SwitchYard application deployed on the system.
        switchyard:read-reference         Returns a details about a SwitchYard reference deployed on the system.
        switchyard:read-service           Returns a details about a SwitchYard service deployed on the system.
        switchyard:reset-metrics          Reset metrics for the specified service/reference/application service.
        switchyard:show-metrics           Displays metrics for the specified service/reference/component service.
        switchyard:throttling             Update throttling settings on a service.
        switchyard:uses-artifact          Returns a list of all SwitchYard applications referencing the specified artifact.











Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 belong 2014-08-11 23:57:27 UTC
This is a duplicate of https://issues.jboss.org/browse/JBFSWDOC-103. Tasks for 6.1 are being handled in JIRA.


Note You need to log in before you can comment on or make changes to this bug.