Bug 1128896 - Havana package is placing bash completion file in wrong location
Summary: Havana package is placing bash completion file in wrong location
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: python-cinderclient
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jakub Ruzicka
QA Contact: nlevinki
URL:
Whiteboard:
: 1128898 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 18:51 UTC by Jacob Walcik
Modified: 2016-04-27 03:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-28 20:47:22 UTC


Attachments (Terms of Use)

Description Jacob Walcik 2014-08-11 18:51:04 UTC
Description of problem: The file to add bash completion support for the Cinder CLI client is being placed in the wrong directory. This is causing errors to appear at login for users who have their shell set to ksh instead of bash.

The file that is being placed at /etc/profile.d/cinder.sh should be in /etc/bash_completion.d instead.

Version-Release number of selected component (if applicable):
python-cinderclient-1.0.7-2.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install python-cinderclient-1.0.7-2.el6.noarch (standalone or as part of a RDO install)
2. Create new user, set user's shell to /bin/ksh
3. Login or use "su -" to switch to alternate user

Actual results:
[root@havana ~]# su - testuser
/etc/profile[70]: .[91]: complete: not found [No such file or directory]
/etc/profile[70]: .[256]: complete: not found [No such file or directory]
$

Expected results:
[root@havana ~]# su - testuser
$

Additional info:
Only the first error is from Cinder. The Neutron client has the same packaging issue.

Comment 1 Lars Kellogg-Stedman 2015-03-28 20:47:22 UTC
This has been corrected in RDO Icehouse and later packages.

Comment 2 Lars Kellogg-Stedman 2015-03-28 20:48:02 UTC
*** Bug 1128898 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.