Bug 1128898 - Havana and Icehouse python-neutronclient packages placing bash completion file in wrong directory
Summary: Havana and Icehouse python-neutronclient packages placing bash completion fil...
Keywords:
Status: CLOSED DUPLICATE of bug 1128896
Alias: None
Product: RDO
Classification: Community
Component: python-neutronclient
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: lpeer
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 18:56 UTC by Jacob Walcik
Modified: 2015-03-28 20:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-28 20:48:02 UTC


Attachments (Terms of Use)

Description Jacob Walcik 2014-08-11 18:56:31 UTC
Description of problem: The file to add bash completion support for the Neutron CLI client is being placed in the wrong directory. This is causing errors to appear at login for users who have their shell set to ksh instead of bash.

The file that is being placed at /etc/profile.d/neutron.sh should be in /etc/bash_completion.d instead.

Version-Release number of selected component (if applicable):
python-neutronclient-2.3.4-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install python-neutronclient-2.3.4-1.el6.noarch (standalone or as part of a RDO install)
2. Create new user, set user's shell to /bin/ksh
3. Login or use "su -" to switch to alternate user

Actual results:
[root@controller01 profile.d]# su - testuser
/etc/profile[70]: .[241]: complete: not found [No such file or directory]
$

Expected results:
[root@havana ~]# su - testuser
$

Additional info:

Comment 1 Lars Kellogg-Stedman 2015-03-28 20:48:02 UTC

*** This bug has been marked as a duplicate of bug 1128896 ***


Note You need to log in before you can comment on or make changes to this bug.