Bug 1128910 - celerybeat service reports incorrect configuration on startup
Summary: celerybeat service reports incorrect configuration on startup
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1172745
TreeView+ depends on / blocked
 
Reported: 2014-08-11 19:47 UTC by Mark Lamourine
Modified: 2017-02-23 21:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1172745 (view as bug list)
Environment:
Last Closed: 2014-12-19 16:48:57 UTC


Attachments (Terms of Use)

Description Mark Lamourine 2014-08-11 19:47:50 UTC
Description of problem:

Celerybeat incorrectly reports the message broker URL on startup.
The reported URL is always localhost

Version-Release number of selected component (if applicable):

Pulp 2.4

How reproducible:

Set the broker_url value in /etc/pulp/server.conf to non-default
Start the Celery service

Steps to Reproduce:
1. Set the broker_url value in /etc/pulp/server.conf to non-default
2. Start the Celery service
3. Observe the startup messages

Actual results:

celery beat v3.1.11 (Cipater) is starting.
__    -    ... __   -        _
Configuration ->
    . broker -> amqp://guest@localhost:5672//
...


Expected results:

celery beat v3.1.11 (Cipater) is starting.
__    -    ... __   -        _
Configuration ->
    . broker -> qpid://guest@myqpidhost:5672/


Additional info:

Comment 1 RHEL Product and Program Management 2014-08-11 19:53:47 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2014-12-19 16:48:57 UTC
Will track this in the upstream bug only as this doesn't impact Satellite 6 directly.


Note You need to log in before you can comment on or make changes to this bug.