Bug 1128948 - python scripts on (double) referenced URL are buggy
Summary: python scripts on (double) referenced URL are buggy
Keywords:
Status: CLOSED DUPLICATE of bug 1136025
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: install-guide
Version: devel
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Bokoc
QA Contact: Fedora Docs QA
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 22:43 UTC by Frantisek Hanzlik
Modified: 2014-09-01 13:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 13:54:24 UTC


Attachments (Terms of Use)

Description Frantisek Hanzlik 2014-08-11 22:43:11 UTC
Description of problem:
First, I must apologize for the inacurrate problem labeling - problem is not in the F20 IG itself, but in (indirect) reference from it.
And as I not know how/where to report it ('https://fedoraproject.org/wiki/Bugs_and_feature_requests?rd=BugsAndFeatureRequests' does not contain instructions how report bugs in wiki pages nor in there referenced articles.
Then I report it here in Bugzilla and hope someone here point me or this problem to right direction.
Problem:
In chapter '15.4. Kickstart Options', for available --xlayouts and --switch 'keyboard' options IG refers to 'https://fedoraproject.org/wiki/Anaconda/Kickstart'. And this Wiki page for list of all available layouts and switching options refers to these scripts:
http://vpodzime.fedorapeople.org/layouts_list.py
http://vpodzime.fedorapeople.org/switching_list.py

And both these scripts seems not working, they give these results:
./layouts_list.py
Traceback (most recent call last):
  File "./layouts_list.py", line 42, in get_language_variants
    lang_name, lang_desc = item_str(item.name), item_str(item.description)
  File "./layouts_list.py", line 8, in item_str
    i = s.find(b'\x00')
AttributeError: 'list' object has no attribute 'find'
...
(this error appears 124 times and nothin else is printed)

./switching_list.py 
Traceback (most recent call last):
  File "./switching_list.py", line 15, in _get_switch_option
    desc = item_str(item.description)
  File "./switching_list.py", line 8, in item_str
    i = s.find(b'\x00')
AttributeError: 'list' object has no attribute 'find'
...
(this error appears 34 times and nothin else is printed)



Version-Release number of selected component (if applicable):
Fedora 20 Installation Guide(OK) -> Anaconda Kickstart wiki(OK) -> scripts

I run these scripts on F19 i686, with this SW installed:
python-2.7.5-13.fc19.i686
libxklavier-5.3-2.fc19.i686
python-xklavier-0.2-11.fc19.i686

Comment 1 Petr Bokoc 2014-09-01 13:54:24 UTC
Hi Frantisek, sorry for taking so long to react.

The scripts aren't necessary at all. All available layouts can be viewed on the xkeyboard-config(7) man page under Layouts; both of the options accept comma-separated lists of layouts as listed on the man page under LAYOUT (for example: "--xlayouts=cz,us") or LAYOUT(VARIANT) (for example: "--xlayouts=cz(bksl),us(euro)".

I'll close this bug because we're going to rewrite the whole Kickstart chapter anyway (for F21) and the other bug covers this issue plus much more. In the meantime, you can also use the Red Hat Enterprise Linux 7 Installation Guide[1] - it will lack some of the options introduced in Fedora 20, but it's significantly more up to date than both the wiki and the current Fedora Installation Guide.

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/sect-kickstart-syntax.html

*** This bug has been marked as a duplicate of bug 1136025 ***


Note You need to log in before you can comment on or make changes to this bug.