Bug 1128986 - [x509]Missing "--ssl-client-key-file" option in the help message of 'rhc server add/configure'
Summary: [x509]Missing "--ssl-client-key-file" option in the help message of 'rhc serv...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 03:13 UTC by Gaoyun Pei
Modified: 2016-05-25 13:20 UTC (History)
5 users (show)

Fixed In Version: rhc-1.29.3.1-1.el6op
Doc Type: Bug Fix
Doc Text:
The --ssl-client-key-file option was missing in the --help output for the 'rhc server add' and 'rhc server configure' commands. This bug fix updates the --help output for these rhc commands, and the option is now shown as expected.
Clone Of:
Environment:
Last Closed: 2014-08-26 13:53:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1095 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.1.5 bug fix and enhancement update 2014-08-26 17:51:34 UTC

Description Gaoyun Pei 2014-08-12 03:13:48 UTC
Description of problem:
When checking the help of command 'rhc server add/configure', found there was no --ssl-client-key-file option in the Usage example and Options list. 
Without --ssl-client-key-file option, adding or configuring a server which is using mutual SSL authentication and x509 certificates would fail.


Version-Release number of selected component (if applicable):
rhc-1.28.5.1-1.el6op.noarch

How reproducible:
always

Steps to Reproduce:
1.rhc server add -h
  rhc server configure -h


Actual results:
Usage: rhc server-configure <server> [--hostname HOSTNAME] [--nickname NICKNAME] [--rhlogin LOGIN] [--[no-]use-authorization-tokens]
[--[no-]insecure] [--use] [--skip-wizard] [--timeout SECONDS] [--ssl-ca-file FILE] [--ssl-client-cert-file FILE] [--ssl-version VERSION]

Options
...
  --timeout SECONDS               The default timeout for operations on this server
  --ssl-ca-file FILE              An SSL certificate CA file (may contain multiple certs) to be used on this server
  --ssl-client-cert-file FILE     An SSL x509 client certificate file to be used on this server
  --ssl-version VERSION           The version of SSL to use to be used on this server
  --server SERVER                 Server hostname or nickname to be configured


Expected results:
Add this option to Usage example to Options list.

Additional info:

Comment 1 openshift-github-bot 2014-08-13 14:45:32 UTC
Commit pushed to master at https://github.com/openshift/rhc

https://github.com/openshift/rhc/commit/329e0f70227255ef924840d5280796b6ced85488
Bug 1128986 - Missing "--ssl-client-key-file" option in the help message of 'rhc server add/configure'

Comment 4 Gaoyun Pei 2014-08-14 03:30:06 UTC
Verify this bug with rhc-1.29.3.1-1.el6op.noarch.


# rhc server add -h
# rhc server configure -h

Options
...
  --ssl-ca-file FILE        An SSL certificate CA file (may contain multiple certs) to be used
                            on this server
  --ssl-client-cert-file    An SSL x509 client certificate file to be used on this server
  FILE
  --ssl-client-key-file     An RSA client certificate key
  FILE
...

Comment 6 errata-xmlrpc 2014-08-26 13:53:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1095.html


Note You need to log in before you can comment on or make changes to this bug.