This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 11290 - IMPS/2, IntelliMouse problem
IMPS/2, IntelliMouse problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-08 00:47 EDT by dh_redhat
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 12:46:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dh_redhat 2000-05-08 00:47:04 EDT
An IntelliMouse w/ IntelliEye does not work in Linux when selecting the
IMPS/2 protocol. The mouse pointer tends to sit in the upper right corner
of the screen or jump all over the place. It also sends "clicks" when just
moving it.

Note that the mouse works fine when selecting a Generic PS/2 mouse in
XF86Config. The hardware is OK because it runs fine in Windows (including
the wheel feature). Also, I moved the mouse to the serial port using a
convertor and it works with the "IntelliMouse" protocol and 'imwheel' in
XFree86.

I am positive this is a driver problem for IMPS/2.

gpm has the same problem, it works fine when selecting PS/2 but not IMPS/2
(I will file a bug against it shortly and update this one with the gpm bug
number).
Comment 1 dh_redhat 2000-05-08 00:49:59 EDT
The bug against gpm is Bug#:11291
Comment 2 rost0031 2000-08-25 02:17:04 EDT
I have the same problem with the same hardware however not as consistent. 
Sometimes, the mouse responds correctly when set to IMPS/2 but would jump around
under the MOUSEMANPS/2+ setting.  Other times, it does the exact opposite.  In
addition to that, my wheel/third button won't work after reboot.  I go through
either mouseconfig or XF86Setup and set everything up.  I startup Xwindows, and
I can use the wheel as the third button.  After reboot, I lose the third
button.  I am using RH6.2, Microsoft Intellimouse Explorer attached to a PS/2
port.
Comment 3 Mike A. Harris 2001-03-06 12:46:25 EST
Try "man -a 4 mouse" and skip the first page that comes up, you're looking
for the XFree86 mouse manual.  In it you'll see the list of all mouse
types.  Try each one that seems to make sense including auto, pnp, and others.
ONe of them should work for you.  If not, please try the latest packages
in my personal FTP space:
ftp://people.redhat.com/mharris/xfree86
Comment 4 Mike A. Harris 2001-03-06 12:46:40 EST
Try "man -a 4 mouse" and skip the first page that comes up, you're looking
for the XFree86 mouse manual.  In it you'll see the list of all mouse
types.  Try each one that seems to make sense including auto, pnp, and others.
ONe of them should work for you.  If not, please try the latest packages
in my personal FTP space:
ftp://people.redhat.com/mharris/xfree86

Note You need to log in before you can comment on or make changes to this bug.