Bug 112918 - LTC5736 - 32 bit glibc not properly installed.
LTC5736 - 32 bit glibc not properly installed.
Status: CLOSED DUPLICATE of bug 137258
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 18:10 EST by Mike Ranweiler
Modified: 2015-01-04 17:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-21 04:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Ranweiler 2004-01-05 18:10:09 EST
Hardware Environment: 64bit iSeries

Software Environment: RHEL 3 QU1


Steps to Reproduce:
1. Install RHEL 3 QU1 from a network based QU1 install source.  Do not
select
the 'Kernel Development' group.
2. After installation add the 'Kernel Development' group using
redhat-config-packages.
3. Attempt to compile a kernel.

Actual Results:
The following error is reported:

[root@rchlp626e linux-2.4.21-6.EL]# make dep
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -o scripts/mkdep
scripts/mkdep.c
/usr/bin/ld: cannot open crt1.o: No such file or directory
collect2: ld returned 1 exit status
make: *** [scripts/mkdep] Error 1

Expected Results:
I expected that both the 32 and 64bit glibc-devel packages would be
installed when I added the 'Kernel Development' group.

Additional Information:
I checked through redhat-config-packages and all the necessary
'Compatibility Arch Development Support', 'Compatibility Arch
Support', 'Kernel Development' and 'Development Tools' packages appear
to be selected.

When I perform an rpm query I see the following:
[root@rchlp626e mnt]# rpm -q --qf
-%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" glibc glibc-devel
glibc-2.3.2-95.6.ppc
glibc-2.3.2-95.6.ppc64
glibc-devel-2.3.2-95.6.ppc64


The 32bit glibc-devel also needs to be installed.  I was able to
resolve the problem by installing the glibc-devel-2.3.2-95.6.ppc rpm.
Comment 1 Jeremy Katz 2004-01-05 18:19:30 EST
This is a package bug in that the kernel-source package doesn't
express that it requires the 32bit glibc.
Comment 2 Julie DeWandel 2004-01-16 14:31:14 EST
Reassigning to Ernie for investigation.Thanks Ernie!
Comment 3 IBM Bug Proxy 2004-02-15 11:48:52 EST
----- Additional Comments From khoa@us.ibm.com  2004-02-15 11:46 -------
Any update on this bug ? 
Comment 4 IBM Bug Proxy 2004-02-15 20:54:30 EST
----- Additional Comments From mranweil@us.ibm.com  2004-02-15 20:54 -------
I don't believe this was on the list for QU2 -> will target for QU3.  Might be
easy, though. 
Comment 7 Bob Johnson 2004-07-20 08:26:34 EDT
IBM, work around exists - not a candidate for U3.
Comment 8 IBM Bug Proxy 2004-07-26 08:09:25 EDT
----- Additional Comments From pbowen@us.ibm.com  2004-07-26 08:09 -------
Per Bob, moving to RHEL4 tgt 
Comment 10 IBM Bug Proxy 2004-08-17 17:06:37 EDT
----- Additional Comments From khoa@us.ibm.com  2004-08-17 15:18 -------
I'd like to defer this bug until RHEL4 for now.  We'll re-open all RHEL3 bugs 
that have RHEL4 as target this week and mirror them to RH as RHEL4 bugs. 
Thanks. 
Comment 11 Jeff Needle 2004-09-13 09:41:38 EDT
Removing from u4 blocker list for now
Comment 12 IBM Bug Proxy 2004-10-27 18:49:54 EDT
----- Additional Comments From pbowen@us.ibm.com  2004-10-27 18:48 EDT -------
Hey RedHat. We need to address this for RHEL4. 
Comment 13 Ernie Petrides 2004-10-27 19:14:14 EDT
Reopened and reassigned to DaveJ per last comment.
Comment 14 IBM Bug Proxy 2004-11-14 17:51:15 EST
----- Additional Comments From pbowen@us.ibm.com  2004-11-14 15:48 EDT -------
Redhat - pls add your comments on where you think that this fix should be 
targeted. 
Comment 15 IBM Bug Proxy 2004-11-16 14:59:43 EST
----- Additional Comments From robbiew@us.ibm.com  2004-11-16 14:56 EDT -------
This bug is a dup of a NEWER bug LTC12085/RH137258, which is where we should
probably continue to work.  I recommend closing this older bug as a DUP. 
Comment 16 Jay Turner 2004-11-21 04:38:59 EST
Closing as a dup as recommended in commnet 15.

*** This bug has been marked as a duplicate of 137258 ***
Comment 17 IBM Bug Proxy 2004-11-22 02:59:23 EST
----- Additional Comments From khoa@us.ibm.com  2004-11-22 02:58 EDT -------


*** This bug has been marked as a duplicate of 12085 *** 
Comment 18 IBM Bug Proxy 2004-11-22 02:59:44 EST
----- Additional Comments From khoa@us.ibm.com  2004-11-22 02:59 EDT -------
Closing this bug report per comments above.  Thanks. 

Note You need to log in before you can comment on or make changes to this bug.