Bug 112919 - bad dependency data for libstdc++-devel-3.2.3-20
bad dependency data for libstdc++-devel-3.2.3-20
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: gcc3 (Show other bugs)
2.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 18:33 EST by Tim Chambers
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 18:44:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Chambers 2004-01-05 18:33:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031107 Debian/1.5-3

Description of problem:
I tried installing gcc-c++-3.2.3-20.ia64.rpm. But libstdc++-devel =
3.2.3 is needed by gcc-c++-3.2.3-20. And libstdc++ = 3.2.3-20 is
needed by libstdc++-devel-3.2.3-20. And package libstdc++-3.2.3-24
(which is newer than libstdc++-3.2.3-20) is already installed.

Version-Release number of selected component (if applicable):
gcc-c++-3.2.3-20

How reproducible:
Always

Steps to Reproduce:
1. install libstdc++-devel-3.2.3-20
2. note it wants libstdc++ = 3.2.3-20, not 24
    

Actual Results:  see above

Expected Results:  Correct dependency is reflected for
libstdc++-devel-3.2.3-20.

Additional info:

I worked around this by using -nodeps.
Comment 1 Jakub Jelinek 2004-01-05 18:44:45 EST
If you have libstdc++-3.2.3-24 installed, you certainly should be trying
installing gcc-c++-3.2.3-24.ia64.rpm, not 3.2.3-20.
Correct dependency is in the packages.
Alternatively, if you really want you can downgrade libstdc++ with
--oldpackage and then install the 32.3-20 packages you want to install.
In any case, up2date solves these things for you.
Comment 2 Tim Chambers 2004-01-06 15:38:42 EST
The I have a different problem. gcc-c++-3.2.3-24.ia64.rpm isn't in my
RHEL3u1 distribution. I'm using re1211. I've heard RHEL3-U1-re1217.0
is available. Should I try that?

# ls *gcc*
kernel unaligned access to 0xe000000000ab3c7a, ip=0xa000000000304a01
kernel unaligned access to 0xe000000000ab3c9a, ip=0xa000000000304a40
kernel unaligned access to 0xe000000000ab3c66, ip=0xa000000000304a41
kernel unaligned access to 0xe000000000ab3caa, ip=0xa000000000304a80
compat-gcc-7.3-2.96.122.ia64.rpm
compat-gcc-c++-7.3-2.96.122.ia64.rpm
gcc-3.2.3-20.ia64.rpm
gcc-c++-3.2.3-20.ia64.rpm
gcc-c++-ssa-3.5ssa-0.20030801.41.ia64.rpm
gcc-g77-3.2.3-20.ia64.rpm
gcc-g77-ssa-3.5ssa-0.20030801.41.ia64.rpm
gcc-gnat-3.2.3-20.ia64.rpm
gcc-java-3.2.3-20.ia64.rpm
gcc-java-ssa-3.5ssa-0.20030801.41.ia64.rpm
gcc-objc-3.2.3-20.ia64.rpm
gcc-objc-ssa-3.5ssa-0.20030801.41.ia64.rpm
gcc-ssa-3.5ssa-0.20030801.41.ia64.rpm
libgcc-3.2.3-20.i386.rpm
libgcc-3.2.3-20.ia64.rpm
libgcc-ssa-3.5ssa-0.20030801.41.ia64.rpm
#

Note You need to log in before you can comment on or make changes to this bug.