Bug 1129233 - Adding new host to local dc fails with JLE
Summary: Adding new host to local dc fails with JLE
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Martin Perina
QA Contact: Jiri Belka
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 11:02 UTC by Ori Gofen
Modified: 2016-05-26 01:50 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-26 09:19:52 UTC
oVirt Team: Infra


Attachments (Terms of Use)
vdsm+engine logs (884.00 KB, application/gzip)
2014-08-12 11:02 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-08-12 11:02:01 UTC
Created attachment 926035 [details]
vdsm+engine logs

Description of problem:

2014-08-12 13:56:24,208 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (org.ovirt.thread.pool-8-thread-28) [280ba52c] java.util.concurrent.ExecutionException: java.lang.re  flect.InvocationTargetException
  2014-08-12 13:56:24,214 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (org.ovirt.thread.pool-8-thread-28) [280ba52c] Command PollVDSCommand(HostName = vdsc, HostId = 0d8b  639c-1e94-489a-a710-d1cd52337d75) execution failed. Exception: RuntimeException: java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
  2014-08-12 13:56:24,840 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (org.ovirt.thread.pool-8-thread-28) [280ba52c] org.ovirt.engine.core.vdsbroker.vdsbroker.VDSRecoveri  ngException: Recovering from crash or Initializing
  2014-08-12 13:56:24,844 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.PollVDSCommand] (org.ovirt.thread.pool-8-thread-28) [280ba52c] Command PollVDSCommand(HostName = vdsc, HostId = 0d8b  639c-1e94-489a-a710-d1cd52337d75) execution failed. Exception: VDSRecoveringException: Recovering from crash or Initializing

Version-Release number of selected component (if applicable):
rc1

How reproducible:
100%


Steps to Reproduce:
1.create local dc
2.add host

Actual results:
engine throws java lang exception

Expected results:
no errors

Additional info:

Comment 1 Martin Perina 2014-08-25 13:34:56 UTC
Hi Ori,

I'm unable to reproduce it either on oVirt master or latest 3.5 RPMs (ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66). On both version I was able to create DC with local storage, to add host to it and to add local storage.

Did you configure something special in this local DC or host (from engine.log I see you did a lot of things before local DC operation where this error appeared)?

Comment 2 Ori Gofen 2014-08-26 09:18:30 UTC
Martin,yes I did,it seems that i did to much.
sorry,can't seem to reproduce this one on the latest version.


Note You need to log in before you can comment on or make changes to this bug.