Bug 1129236 - several dependencies problem on Centos 7
Summary: several dependencies problem on Centos 7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ioprocess
Version: 3.5
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Antonin Pagac
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 11:07 UTC by Netbulae
Modified: 2014-12-15 15:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-15 06:09:19 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31401 master MERGED packaging: add ioprocess from EPEL Never
oVirt gerrit 31408 master MERGED packaging: add rubygem-rgen deps for puppet Never

Description Netbulae 2014-08-12 11:07:32 UTC
Description of problem:

--> Processing Dependency: ioprocess = 0.10.0-1.el7 for package: python-ioprocess-0.10.0-1.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-ioprocess-0.10.0-1.el7.noarch (ovirt-3.5-epel)
           Requires: ioprocess = 0.10.0-1.el7
           Available: ioprocess-0.9.0-1.el7.x86_64 (ovirt-3.5-pre)
               ioprocess = 0.9.0-1.el7

Version-Release number of selected component (if applicable):

ovirt-release35-001-0.4.rc1.noarch

Workaround:

add ioprocess to "includepkgs=" in [ovirt-3.5-epel] repo

Comment 1 Dan Kenigsberg 2014-08-12 11:36:33 UTC
Please note that the required version is available from EPEL:

ftp://anorien.csc.warwick.ac.uk/epel/beta/7/x86_64/ioprocess-0.10.0-1.el7.x86_64.rpm

Comment 3 Netbulae 2014-08-12 13:53:17 UTC
Thanks. 

Now I get the next one:

Resolving Dependencies
--> Running transaction check
---> Package ioprocess.x86_64 0:0.9.0-1.el7 will be updated
---> Package ioprocess.x86_64 0:0.10.0-1.el7 will be an update
---> Package puppet.noarch 0:3.6.2-1.el7 will be updated
---> Package puppet.noarch 0:3.6.2-2.el7 will be an update
--> Processing Dependency: rubygem(rgen) for package: puppet-3.6.2-2.el7.noarch
---> Package python-ioprocess.noarch 0:0.9.0-1.el7 will be updated
---> Package python-ioprocess.noarch 0:0.10.0-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: puppet-3.6.2-2.el7.noarch (ovirt-3.5-epel)
           Requires: rubygem(rgen)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Wich I worked around by removing puppet from the "includepkgs=" line

The update of ioprocess went fine then.

Comment 4 Sandro Bonazzola 2014-08-12 14:28:52 UTC
Hi Netbulae, can you retry with http://jenkins.ovirt.org/job/ovirt-release_master_gerrit/99/artifact/exported-artifacts/ovirt-release35-001-0.5.rc2.noarch.rpm ? I added rubygem to includepkgs.

Comment 5 Sandro Bonazzola 2014-08-12 14:29:29 UTC
If you encounter further missing dependencies, can you keep adding to includepkgs and provide the complete list?

Comment 6 Netbulae 2014-08-12 14:55:46 UTC
Hi Sandro,

No you added "ruby-gem" to it, but the packagename is "rubygem-rgen"

Comment 8 Netbulae 2014-08-12 15:23:41 UTC
Works! No more dep problems

Comment 9 Sandro Bonazzola 2014-08-12 15:24:39 UTC
(In reply to Netbulae from comment #8)
> Works! No more dep problems

Thanks!

Comment 10 Gil Klein 2014-10-15 06:09:19 UTC
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA


Note You need to log in before you can comment on or make changes to this bug.