Bug 1129283 - POSIX ACLs are not replicated onto the slave volume, in RHS2.1 geo-replication
Summary: POSIX ACLs are not replicated onto the slave volume, in RHS2.1 geo-replication
Keywords:
Status: CLOSED DUPLICATE of bug 1063028
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Aravinda VK
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
: 1149595 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 13:42 UTC by Vimal Kumar
Modified: 2015-01-05 07:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-05 07:04:30 UTC


Attachments (Terms of Use)

Description Vimal Kumar 2014-08-12 13:42:34 UTC
a) Description of problem:

POSIX ACLs are not replicated onto the slave volume, in RHS geo-replication.

The ACLs can be listed properly on the master-volume. The files are replicated fine onto the slave volume, but the ACLs are not.

b) Version-Release number of selected component (if applicable):

glusterfs-3.4.0.59rhs-1.el6rhs
glusterfs-geo-replication-3.4.0.59rhs-1.el6rhs
glusterfs-fuse-3.4.0.59rhs-1.el6rhs

c) How reproducible:

Always

d) Steps to Reproduce:

1) Create a master volume with two bricks
2) Create a slave volume with two bricks.
3) Mount the master volume and slave volume onto two client machines, with the '-o acl' option.
4) Start a geo-replication session from the master volume to the slave volume.
5) Create a few files at the master volume mount-point.
6) Set an ACL for a user, on the files. (setfacl -m u:test:rwx /<mount-point>/<file-name>.txt)
7) Do an 'ls -l' on the master-vol mount point to check if the '+' is listed on the file
8) Check if the ACLs are listed on the file from the master-vol mount point, using 'getfacl'.
9) Check the same steps ('ls -l', and 'getfacl') from the slave-volume mount point.
10) The '+' sign in the permission field won't be listed, as well as any outputs for 'setfacl'.

e) Actual results:

The ACLs is not replicated over to the slave volume.

f) Expected results:

The ACLs should be replicated to the slave volume.

g) Additional info:

The gfid for the files on the bricks (constituting the master volume and slave volume are same). We have another bug https://bugzilla.redhat.com/show_bug.cgi?id=1060683 which shows a difference of trusted.gfid value for the same file on the master and slave volume. This is not the case here.

Comment 5 Aravinda VK 2015-01-05 07:03:12 UTC
*** Bug 1149595 has been marked as a duplicate of this bug. ***

Comment 6 Aravinda VK 2015-01-05 07:04:30 UTC

*** This bug has been marked as a duplicate of bug 1063028 ***


Note You need to log in before you can comment on or make changes to this bug.