Bug 1129388 - Permit IPV6 hostnames in rsyslog.conf
Summary: Permit IPV6 hostnames in rsyslog.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: augeas
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 15:52 UTC by Ryan Barry
Modified: 2015-03-05 09:25 UTC (History)
2 users (show)

Fixed In Version: augeas-1.1.0-13.el7
Doc Type: Bug Fix
Doc Text:
Cause: IPv6 IP addresses in rsyslog.conf entries could not be parsed Consequence: Augeas would fail to parse rsyslog.conf Fix: Augeas will now parse IPv6 addresses specified in entries, e.g. @@[2001::1] Result: Augeas can now parse rsyslog.conf files containing IPv6 addresses
Clone Of:
Environment:
Last Closed: 2015-03-05 09:25:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0399 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-03-05 14:17:57 UTC

Description Ryan Barry 2014-08-12 15:52:10 UTC
Description of problem:
rsyslog supports IPV6 remotes, but augeas does nto suport this

Version-Release number of selected component (if applicable):
augeas-1.1.0-12

How reproducible:
Always

Steps to Reproduce:
1. Add an IPV6 remote in rsyslog.conf
2. Attempt to do anything with augeas

Actual results:
The syslog lens doesn't get a complete path match

Expected results:
augeas/augtool work

Additional info:
It looks like the loghost_r regexp in the syslog lens doesn't support IPv6 formats

Ex:
*.* @[2001::1]:514

Comment 2 Dominic Cleal 2014-09-03 15:33:15 UTC
Removing RFE tags as this is valid syntax, so treating it as a bug.

Fixed in a94ad3e6ca467acd03b38c9964f9c3c773a646a5

Comment 4 Lingfei Kong 2014-09-16 08:12:03 UTC
Can verify with augeas-1.1.0-13.el7

Steps to verify:
#cat /etc/rsyslog.conf
*.* @[2001::1]:514

#augtool print /files/etc/rsyslog.conf
/files/etc/rsyslog.conf
/files/etc/rsyslog.conf/entry
/files/etc/rsyslog.conf/entry/selector
/files/etc/rsyslog.conf/entry/selector/facility = "*"
/files/etc/rsyslog.conf/entry/selector/level = "*"
/files/etc/rsyslog.conf/entry/action
/files/etc/rsyslog.conf/entry/action/hostname = "[2001::1]"
/files/etc/rsyslog.conf/entry/action/port = "514"

Comment 6 errata-xmlrpc 2015-03-05 09:25:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0399.html


Note You need to log in before you can comment on or make changes to this bug.