Bug 1129448 - Misleading error message when trying to remove RH content via bulk actions
Summary: Misleading error message when trying to remove RH content via bulk actions
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Katello QA List
URL:
Whiteboard:
: 1202698 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 19:27 UTC by Corey Welton
Modified: 2017-01-16 18:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 18:20:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 17744 None None None 2016-12-19 17:10:02 UTC

Description Corey Welton 2014-08-12 19:27:16 UTC
Description of problem:
Obv. we cannot outright remove RH content via bulk actions, but when user tries to do so, an error is returned that is misleading.



Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140806.0

How reproducible:


Steps to Reproduce:
1.  Sync RH content.  If you want, to better illustrate this BZ, add it to a CV and publish, but subsequently remove all traces of CV (remove published version, delete) and assure it is GONE.
2.  Content > Products > $RH_Content > Bulk delete > Remove Products > Remove
3.  View results

Actual results:
Misleading error message:

An error occurred removing the Products: Cannot delete a Red Hat Products or Products with Repositories published in a Content View


Expected results:

Perhaps we should disallow users to go through the workflow with RH content, blacklist it, or maybe we should eventually just allow users to remove. 

However, at very least we should not presently display message above, when content is definitely not in any content views.

Additional info:

Comment 2 Brad Buckingham 2016-04-28 19:35:47 UTC
*** Bug 1202698 has been marked as a duplicate of this bug. ***

Comment 3 Brad Buckingham 2016-04-28 19:37:03 UTC
Refer also to bug 1202698 when fixing this one.

Comment 4 Brad Buckingham 2016-12-19 17:09:59 UTC
Created redmine issue http://projects.theforeman.org/issues/17744 from this bug

Comment 5 Corey Welton 2017-01-16 18:20:03 UTC
This is an older bug which has been reported upstream. We are not going to track this bug downstream. When the upstream issue is resolved, the next build will contain the fix. Thank you.


Note You need to log in before you can comment on or make changes to this bug.