Bug 1129522 - [virtio-win][virtio scsi][rhel6]Downgrade virtio scsi driver and restart guest failed
Summary: [virtio-win][virtio scsi][rhel6]Downgrade virtio scsi driver and restart gues...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2014-08-13 05:09 UTC by Min Deng
Modified: 2016-12-14 03:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 03:30:57 UTC


Attachments (Terms of Use)
guest (42.30 KB, image/png)
2014-08-13 05:09 UTC, Min Deng
no flags Details

Description Min Deng 2014-08-13 05:09:28 UTC
Created attachment 926254 [details]
guest

Description of problem:
Downgrade virtio scsi driver and restart guest failed

Version-Release number of selected component (if applicable):
build 86 
kernel-2.6.32-492.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.430.el6.x86_64
How reproducible:
2/2 

Steps to Reproduce:
1.boot up guest with two virtio scsi pcis (system disk and data disks)
  /usr/libexec/qemu-kvm -M pc -m 2G -smp 2 -cpu host -usb -device usb-tablet -device virtio-scsi-pci,bus=pci.0,addr=0x5,id=scsi0 -device scsi-hd,bus=scsi0.0,drive=drive-ide0-0-0,id=scsi2,bootindex=1 -drive file=win81-32.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=unsafe,serial=abcdefghtfdfdsfsdfsdfsdfsdfdsf000 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=00:52:4f:65:25:31,id=net0 -uuid 4870b5fd-65d1-488a-9333-3c4e095285b0 -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=a111,path=/tmp/monitor-win2012-serial,server,nowait -mon chardev=a111,mode=readline -vnc :4 -vga cirrus -monitor stdio -drive file=testscsi.raw,if=none,id=drive-scsi0-0-0,if=none,media=disk,cache=writeback,format=raw,werror=stop,aio=native,readonly=off -device scsi-hd,bus=scsi0.0,drive=drive-scsi0-0-0,id=scsi1,scsi-id=254,lun=10 -drive file=en_windows_8_1_enterprise_x86_dvd_2971902.iso,if=none,media=cdrom,format=raw,id=drive-ide1-0-1 -device ide-drive,drive=drive-ide1-0-1,id=ide1-0-1,bootindex=2 -drive file=/home/virtio-win-86-rng.iso,if=none,media=cdrom,format=raw,id=drive-ide1-0-2 -device ide-drive,drive=drive-ide1-0-2,id=ide1-0-2 -fda 86-block-32.vfd -qmp tcp:0:3333,server,nowait -device virtio-scsi-pci,id=bus2 -device scsi-hd,bus=bus2.0,drive=scsi-disk5,id=disk5,serial=test5 -drive file=disk5.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=unsafe,aio=native,id=scsi-disk5
2.downgrade virtio scsi driver from build 86 to build 75 or 83
  from Device Manager -> downgrade the data disk virtio scsi driver and one message will tell you restart machine,please click "yes"   

Actual results:
The guest could not boot up again please see screen shot.

Expected results:
The guest could boot up successfully.

Additional info:

Comment 2 Ronen Hod 2014-08-14 16:21:28 UTC
Deferred to 7.2, due to priorities.


Note You need to log in before you can comment on or make changes to this bug.