Bug 1129581 - The size of docker built image always is zero in json file
Summary: The size of docker built image always is zero in json file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: William Henry
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 09:08 UTC by Guohua Ouyang
Modified: 2019-03-06 02:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-14 16:44:25 UTC


Attachments (Terms of Use)

Description Guohua Ouyang 2014-08-13 09:08:10 UTC
Description of problem:
The size of the docker built image is always zero.
It seems the size means the incremental size from its parent image, but it's confused to me because I think it report the image rhel size as the docker images reported, checked on fedora, it has the same problem.

Suggestions:
1. change the key "Size" to "IncSize" if it means incremental size.
or
2. report the image real size, because the meaning of "incremental size" is not so obviously to users.

# docker inspect gouyang/mariadb | tail
        "WorkingDir": ""
    },
    "Created": "2014-08-13T08:21:08.680510709Z",
    "DockerVersion": "1.1.2",
    "Id": "6144fafe7bf37fb8b9439ad33017cef6965623c0c5bcaa731afb76e0b9d58f2e",
    "Os": "linux",
    "Parent": "b59e7f115314a94af50223c8d0636f69dfaac4badf3dc52ce19f07c78de907ed",
    "Size": 0
}

# docker images gouyang/mariadb
REPOSITORY          TAG                 IMAGE ID            CREATED             VIRTUAL SIZE
gouyang/mariadb     latest              6144fafe7bf3        26 minutes ago      351.4 MB

Version-Release number of selected component (if applicable):
docker-1.1.2-9.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Daniel Walsh 2014-10-24 20:17:00 UTC
Fixed in docker-1.3.


Note You need to log in before you can comment on or make changes to this bug.