Bug 1129605 - [abrt] libreoffice-core-4.0.4.2-13.el6: enumerator_files_callback: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] libreoffice-core-4.0.4.2-13.el6: enumerator_files_callback: Process /u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk2
Version: 6.6
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Benjamin Otte
QA Contact: Desktop QE
URL:
Whiteboard: abrt_hash:b11c7aac07c0ef40d66f6401565...
: 1129657 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 10:34 UTC by Jiri Koten
Modified: 2014-10-14 07:41 UTC (History)
6 users (show)

Fixed In Version: gtk2-2.24.23-5.el6
Doc Type: Bug Fix
Doc Text:
Cause: a race between an asynchronous directory listing operation and the file chooser performing the operation closing Consequence: a crash when saving a file on a mounted remote sftp file share. Fix: check for cancellation of the asychronous operation before processing its completion Result: no crash
Clone Of:
Environment:
Last Closed: 2014-10-14 07:41:22 UTC


Attachments (Terms of Use)
File: open_fds (844 bytes, text/plain)
2014-08-13 10:34 UTC, Jiri Koten
no flags Details
File: dso_list (19.85 KB, text/plain)
2014-08-13 10:34 UTC, Jiri Koten
no flags Details
File: last_occurrence (10 bytes, text/plain)
2014-08-13 10:34 UTC, Jiri Koten
no flags Details
File: var_log_messages (354 bytes, text/plain)
2014-08-13 10:34 UTC, Jiri Koten
no flags Details
File: maps (77.93 KB, text/plain)
2014-08-13 10:34 UTC, Jiri Koten
no flags Details
File: backtrace (61.67 KB, text/plain)
2014-08-13 10:34 UTC, Jiri Koten
no flags Details
File: limits (1.29 KB, text/plain)
2014-08-13 10:34 UTC, Jiri Koten
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1554 normal SHIPPED_LIVE gtk2, gdk-pixbuf2, librsvg2, and libwmf bug fix and enhancement update 2014-10-14 01:27:57 UTC

Description Jiri Koten 2014-08-13 10:34:08 UTC
Description of problem:
Save file on sftp share.

Version-Release number of selected component:
libreoffice-core-4.0.4.2-13.el6

Additional info:
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=6
crash_function: enumerator_files_callback
kernel:         2.6.32-495.el6.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 enumerator_files_callback at gtkfilesystem.c
: #1 next_async_callback_wrapper at gfileenumerator.c
: #2 complete_in_idle_cb at gsimpleasyncresult.c
: #7 IA__gtk_dialog_run at gtkdialog.c
: #8 RunDialog::run at /usr/src/debug/libreoffice-4.0.4.2/vcl/unx/gtk/fpicker/SalGtkPicker.cxx
: #9 SalGtkFilePicker::execute at /usr/src/debug/libreoffice-4.0.4.2/vcl/unx/gtk/fpicker/SalGtkFilePicker.cxx
: #10 sfx2::FileDialogHelper_Impl::implDoExecute at /usr/src/debug/libreoffice-4.0.4.2/sfx2/source/dialog/filedlghelper.cxx
: #11 sfx2::FileDialogHelper_Impl::execute at /usr/src/debug/libreoffice-4.0.4.2/sfx2/source/dialog/filedlghelper.cxx
: #12 sfx2::FileDialogHelper::Execute at /usr/src/debug/libreoffice-4.0.4.2/sfx2/source/dialog/filedlghelper.cxx
: #13 ModelData_Impl::OutputFileDialog at /usr/src/debug/libreoffice-4.0.4.2/sfx2/source/doc/guisaveas.cxx

Comment 1 Jiri Koten 2014-08-13 10:34:10 UTC
Created attachment 926361 [details]
File: open_fds

Comment 2 Jiri Koten 2014-08-13 10:34:12 UTC
Created attachment 926362 [details]
File: dso_list

Comment 3 Jiri Koten 2014-08-13 10:34:14 UTC
Created attachment 926363 [details]
File: last_occurrence

Comment 4 Jiri Koten 2014-08-13 10:34:15 UTC
Created attachment 926364 [details]
File: var_log_messages

Comment 5 Jiri Koten 2014-08-13 10:34:18 UTC
Created attachment 926365 [details]
File: maps

Comment 6 Jiri Koten 2014-08-13 10:34:21 UTC
Created attachment 926366 [details]
File: backtrace

Comment 7 Jiri Koten 2014-08-13 10:34:22 UTC
Created attachment 926367 [details]
File: limits

Comment 10 Jiri Koten 2014-08-13 12:34:30 UTC
*** Bug 1129657 has been marked as a duplicate of this bug. ***

Comment 11 Jiri Koten 2014-08-13 12:36:31 UTC
Cannot reproduce for 100%, but I'm able to reproduce with multiple retries.

Comment 12 Ray Strode [halfline] 2014-08-22 20:17:19 UTC
So this is a race condition sort of inherent in how GSimpleAsyncResult works in the version of glib we ship in rhel6.  It's possible for an asynchronous operation to finish and the associated callback to get called just as the operation is cancelled.  That's what's happening here, and so the callback is getting called with freed user data.  

Later versions of glib make it possible for the implementor of the async operation to close this race with a new function:

g_simple_async_result_set_check_cancellable

but getting this api added to rhel6 glib and then changing gtk to use it  doesn't seem worth the churn. especially since GSimpleAsyncResult has been superceded these days by GTask

The simplest patch is to store the cancellable on the source object as object data and check if it's cancelled at the operation finish time (in addition to the g_error_matches (error, G_IO_ERROR, G_IO_ERROR_CANCELLED) checking already being performed)

gtk2 is already on the approved components list and i have a patch so devack+

Comment 15 errata-xmlrpc 2014-10-14 07:41:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1554.html


Note You need to log in before you can comment on or make changes to this bug.