Bug 1129784 - error using Hackbench.__del__ after hwcert-backend run
Summary: error using Hackbench.__del__ after hwcert-backend run
Keywords:
Status: NEW
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)
Version: 1.6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL: http://hwcert-server.khw.lab.eng.bos....
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 16:01 UTC by Brian Brock
Modified: 2018-03-22 20:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Brian Brock 2014-08-13 16:01:23 UTC
Description of problem:
error message in output from hwcert-backend run -t realtime

Version-Release number of selected component (if applicable):
hwcert-client-20140731 (retesting with more recent version)

How reproducible:
trying to reproduce now

Steps to Reproduce:
1. install hwcert-client on rhel 6
2. install and boot the -rt kernel
2. hwcert-backend plan
3. hwcert-backend run -t realtime

other tests have not yet been tried


Actual results:
error in output printed to screen.  No error in output.log

Expected results:
No error printed on screen

Additional info:
output ends with:

Your sosreport has been generated and saved in:
/tmp/sosreport-intel-sharkbay-dh-01-20140813040733-0220.tar.xz
Copied sosreport --batch -n selinux /tmp/sosreport-intel-sharkbay-dh-01-20140813040733-0220.tar.xz to /var/log/hwcert/runs/4/info
PASS
Exception TypeError: 'an integer is required' in <bound method Hackbench.__del__ of <Hackbench(hackbench, stopped 140495911503616)>> ignored
copying attachments...
checking directory /var/log/hwcert/runs/4/info
Adding /var/log/hwcert/runs/4/info/sosreport-intel-sharkbay-dh-01-20140813040733-0220.tar.xz
copied attachment file sosreport-intel-sharkbay-dh-01-20140813040733-0220.tar.xz
Skipping output.log
saveOutput: /var/log/hwcert/runs/4/info/output.log
Return value was 0

Comment 1 Guangze Bai 2014-08-14 16:09:05 UTC
Is it always reproducible?
What's the version of package rteval?


Note You need to log in before you can comment on or make changes to this bug.