Bug 1129789 - F19 PXE boot drops into Dracut Emergency Shell
Summary: F19 PXE boot drops into Dracut Emergency Shell
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 16:42 UTC by Matt Woelfel
Modified: 2014-10-27 21:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 21:11:13 UTC


Attachments (Terms of Use)

Description Matt Woelfel 2014-08-13 16:42:14 UTC
Description of problem:
I created a Fedora 19 live CD and PXE image using mock on Fedora 20.  The PXE image boots fine if I do NOT have updates repo enabled.  When booting the PXE image built with the updates repo enabled I get:

Warning: /dev/mapper/live-rw does not exist
    Starting Dracut Emergency Shell...

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Build a Fedora 19 live cd with the updates repo enabled
1.1. livecd-creator --cache=cache /usr/share/spin-kickstarts/fedora-live-desktop.ks
2. Convert the image to pxe and load onto a server
2.1. livecd-iso-to-pxeboot livecd-fedora-live-desktop-201408131009.iso
2.2. tftpconfig:
LABEL F19
    KERNEL Images/Ssdt/f19/vmlinuz0
    APPEND rootflags=loop initrd=Images/Ssdt/f19/initrd0.img root=live:/livecd-fedora-live-desktop-201408111655.iso rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 mem=8G
3. Boot a client machine

Actual results:
Drop into the Dracut Emegency Shell.

Expected results:
PXE image boots to the Desktop.

Additional info:
I tried holding back some packages, but I haven't found one that seems to improve the situation:

repo --name=updates --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch --exclude=dracut* --exclude=systemd* --exclude=*abrt* --exclude=libgudev1 --exclude=device-mapper* --exclude=lvm2 --exclude=kernel*

Comment 1 Brian Lane 2014-08-13 21:11:13 UTC
This is going to be a bug with one of the updated packages, not livecd-tools.

Comment 2 Matt Woelfel 2014-08-14 00:47:57 UTC
Can you point me to where I should file this bug?  Since a component is required in filing the bug report, livecd-tools seemed to be the best resource for looking into this, as you probably have a way to verify that the images are being properly generated.  Note that the live cd output works fine, but it's the PXE image that's failing.

Thanks,

Matt

Comment 3 Jonathan Dieter 2014-10-27 13:28:02 UTC
For what it's worth, I ran into this.  After upgrading my PXE image to F20, it worked again.

Comment 4 Brian Lane 2014-10-27 21:11:25 UTC
(In reply to Matt Woelfel from comment #2)
> Can you point me to where I should file this bug?  Since a component is
> required in filing the bug report, livecd-tools seemed to be the best
> resource for looking into this, as you probably have a way to verify that
> the images are being properly generated.  Note that the live cd output works
> fine, but it's the PXE image that's failing.

Sorry, but you'll have to track it down yourself -- there are too many variables in play. Running with rd.debug will make dracut dump lots of info about what it is doing which may reveal what the problem is.


Note You need to log in before you can comment on or make changes to this bug.