Bug 1129816 - cpuspeed package for RHEL 5.11 (1.2.1-11.el5) is older than the cpuspeed erratum we shipped for 5.10
Summary: cpuspeed package for RHEL 5.11 (1.2.1-11.el5) is older than the cpuspeed erra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cpuspeed
Version: 5.11
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 17:48 UTC by Mike Gahagan
Modified: 2015-02-26 08:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-26 08:57:38 UTC


Attachments (Terms of Use)

Description Mike Gahagan 2014-08-13 17:48:37 UTC
Description of problem:

TPS RHNQA in the errata tool found an issue with our 5.11 cpuspeed package. Here is what I think happened:

We cut a new cpuspeed package for 5.11 to fix bz 887256 (1.2.1-11.el5). Some time later we got a request to build a z-stream package with the same fix in it (1.2.1-11.el5_10, bz 1078211) and we released it. Systems with cpuspeed installed now can only update to version 1.2.1-11.el5_10 since rpm considers that package to be newer than 1.2.1-11.el5. 

It appears that we need to re-spin cpuspeed to bump up the release number so it will appear to be newer than the 5.10.z version. No code changes should be needed.

Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-11.el5_10 & cpuspeed-1.2.1-11.el5

How reproducible:
always

Steps to Reproduce:
1. Try an yum update to 5.11 cpuspeed with the 5.10.z version installed.
2.
3.

Actual results:
only cpuspeed-1.2.1-11.el5_10 is available

Expected results:
5.11 version of cpuspeed needs a higher release number so it appears newer to rpm/yum

Additional info:

Comment 1 Petr Šabata 2014-08-14 07:55:19 UTC
I think this is a rather common situation.  Is the update even necessary?  The contents of the packages are identical and any hypothetical future updates would automatically update from 1.2.1-11.el5_10 to 1.2.1-12.el5+.

Comment 3 Joe Orton 2015-02-26 08:57:38 UTC
This was resolved by dropping the 5.11 errata.


Note You need to log in before you can comment on or make changes to this bug.