Bug 112985 - spanish lang. and awk
spanish lang. and awk
Status: CLOSED DUPLICATE of bug 113423
Product: Fedora
Classification: Fedora
Component: gawk (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-06 17:29 EST by Roberto Arro
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roberto Arro 2004-01-06 17:29:19 EST
Description of problem:
Using awk with spanish ("," as decimal separator), when the numbers
are less than 1 do not take decimals.

Version-Release number of selected component (if applicable):


How reproducible:
Using this example:
$ echo 3,456 | awk '{print 10*$1}'
$ 34,56  OK!

$ echo 0,456 | awk '{print 10*$1}'
$ 0    It looks as a bug


Steps to Reproduce:
1.    echo 0,456 | awk '{print 10*$1}
2.
3.
  
Actual results:
0

Expected results:
4,53

Additional info:
Comment 1 Leon Ho 2004-01-08 00:23:36 EST
Look like it is a gawk bug? 
Comment 2 Florian La Roche 2004-01-14 02:55:10 EST
Duplicate of #113423?


*** This bug has been marked as a duplicate of 113423 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:00:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.