Bug 1129872 - pciehp errors flooding dmesg
Summary: pciehp errors flooding dmesg
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 20:12 UTC by Dustin Henning
Modified: 2014-11-13 18:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-13 18:23:21 UTC


Attachments (Terms of Use)
dmesg was cut off by the time I could run it, this is logs in /var/log/messages from before the start of dmesg (99.61 KB, text/plain)
2014-08-13 20:12 UTC, Dustin Henning
no flags Details
dmesg from immediately after logging in post-boot (135.90 KB, text/plain)
2014-08-13 20:13 UTC, Dustin Henning
no flags Details
lspci, shows error refors to PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port (1.98 KB, text/plain)
2014-08-13 20:14 UTC, Dustin Henning
no flags Details
lsmod, may show if some module is trying to use PCIEx Hotplug? (3.37 KB, text/plain)
2014-08-13 20:15 UTC, Dustin Henning
no flags Details

Description Dustin Henning 2014-08-13 20:12:49 UTC
Created attachment 926562 [details]
dmesg was cut off by the time I could run it, this is logs in /var/log/messages from before the start of dmesg

Description of problem:
System is MSI P965 Platinum (Intel ICH8R)

Upon install of Fedora, the terminal, dmesg, and /var/log/messages are flooded with messages like these:
Aug 13 15:56:24 f20test kernel: pciehp 0000:00:1c.4:pcie04: Failed to check link status
Aug 13 15:56:24 f20test kernel: pciehp 0000:00:1c.4:pcie04: No adapter on slot(0)
Aug 13 15:56:24 f20test kernel: [  142.676160] pciehp 0000:00:1c.4:pcie04: Card not present on Slot(0)
Aug 13 15:56:24 f20test kernel: pciehp 0000:00:1c.4:pcie04: Card not present on Slot(0)


Version-Release number of selected component (if applicable):
3.15.8-200.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install on P965 Platinum
2. Boot and watch the terminal (or dmesg or messages)

Actual results:
/var/log/messages filled with pciehp errors.

Expected results:
Terminal should be usable and messages should not consume massive amounts of disk space.

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=529153
http://askubuntu.com/questions/10122/why-does-my-kernel-log-file-report-link-training-error-and-failed-to-check-li

Comment 1 Dustin Henning 2014-08-13 20:13:43 UTC
Created attachment 926566 [details]
dmesg from immediately after logging in post-boot

Comment 2 Dustin Henning 2014-08-13 20:14:20 UTC
Created attachment 926567 [details]
lspci, shows error refors to PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port

Comment 3 Dustin Henning 2014-08-13 20:15:03 UTC
Created attachment 926568 [details]
lsmod, may show if some module is trying to use PCIEx Hotplug?

Comment 4 Dustin Henning 2014-08-13 20:41:06 UTC
After reviewing 529153, I can add the following:

I can confirm that in F20, pcie_ports=compat does remove these messages at least.

Specifically, I added that to the end of the GRUB_CMDLINE_LINUX line in /etc/default/grub and ran grub2-mkconfig > /boot/grub2/grub.cfg as root, and the message is not showing up after reboots.

That having been said, I will try to make myself available for any additional testing that may be necessary / available to resolve the issue so that it doesn't need worked around, but I may need explicit instructions in order to help with said testing.

Comment 5 Justin M. Forbes 2014-11-13 16:03:00 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.

Comment 6 Dustin Henning 2014-11-13 18:17:01 UTC
After upgrading to 3.17.2-200.fc20.x86_64 using yum update, I do not see this behavior even when booting into 3.15.8-200.fc20.x86_64.

Comment 7 Josh Boyer 2014-11-13 18:23:21 UTC
Thank you.


Note You need to log in before you can comment on or make changes to this bug.