Bug 1130003 - Multiple packages installation fail due to dependency problems when test RHEL6.6 Beta Workstation i386
Summary: Multiple packages installation fail due to dependency problems when test RHEL...
Keywords:
Status: CLOSED DUPLICATE of bug 1130083
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.6
Hardware: i386
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 07:22 UTC by haiwang
Modified: 2015-04-13 22:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 13:01:48 UTC


Attachments (Terms of Use)

Description haiwang 2014-08-14 07:22:16 UTC
Description of problem:

Multiple packages installation fail due to dependency problems when test RHEL6.6 Beta Workstation i386.
Version-Release number of selected component (if applicable):

RHEL6.6 Beta Workstation i386.
How reproducible:


Steps to Reproduce:
1. Register and Subscribe 
#subscription-manager register --username=stage_rhscl_dts_test --password='redhat'
======  Register successfully...  ======
#subscription-manager subscribe --pool=8a99f98146b4fa9d0146b56be0751c9a
======  Subscribe successfully...  ======

2.Enable related repos
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-optional-beta-rpms  ======
Repo 'rhel-6-workstation-optional-beta-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-optional-beta-source-rpms  ======
Repo 'rhel-6-workstation-optional-beta-source-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-beta-rpms  ======
Repo 'rhel-6-workstation-beta-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-beta-debug-rpms  ======
Repo 'rhel-6-workstation-beta-debug-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-supplementary-beta-source-rpms  ======
Repo 'rhel-6-workstation-supplementary-beta-source-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-beta-source-rpms  ======
Repo 'rhel-6-workstation-beta-source-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-supplementary-beta-rpms  ======
Repo 'rhel-6-workstation-supplementary-beta-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-optional-beta-debug-rpms  ======
Repo 'rhel-6-workstation-optional-beta-debug-rpms' is enabled for this system.
======  enable repo successfully: subscription-manager repos --enable=rhel-6-workstation-supplementary-beta-debuginfo  ======

3. yum install -y --skip-broken mpich2-devel boost-mpich2-devel boost-mpich2 boost-mpich2-python boost-graph-mpich2 

Actual results:
Loaded plugins: product-id, security, subscription-manager
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package boost-graph-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: boost-serialization = 1.41.0-24.el6 for package: boost-graph-mpich2-1.41.0-24.el6.i686
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libboost_serialization.so.5 for package: boost-graph-mpich2-1.41.0-24.el6.i686
--> Processing Dependency: libboost_serialization-mt.so.5 for package: boost-graph-mpich2-1.41.0-24.el6.i686
---> Package boost-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: mpich2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-mpich2-devel.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: boost-devel = 1.41.0-24.el6 for package: boost-mpich2-devel-1.41.0-24.el6.i686
---> Package boost-mpich2-python.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: boost-python = 1.41.0-24.el6 for package: boost-mpich2-python-1.41.0-24.el6.i686
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libboost_python.so.5 for package: boost-mpich2-python-1.41.0-24.el6.i686
--> Processing Dependency: libboost_python-mt.so.5 for package: boost-mpich2-python-1.41.0-24.el6.i686
---> Package mpich2-devel.i686 0:1.2.1-2.3.el6 will be installed
--> Processing Dependency: mpich2 = 1.2.1-2.3.el6 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichf90.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libfmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package boost-devel.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: boost = 1.41.0-24.el6 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_wave-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_unit_test_framework.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_unit_test_framework-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_thread-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_system.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_system-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_signals.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_signals-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_regex.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_regex-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_program_options.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_program_options-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_prg_exec_monitor.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_prg_exec_monitor-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_tr1l.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_tr1l-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_tr1f.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_tr1f-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_tr1.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_tr1-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_c99l.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_c99l-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_c99f.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_c99f-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_c99.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_math_c99-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_iostreams.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_iostreams-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_graph.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_graph-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_filesystem.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_filesystem-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_date_time.so.5 for package: boost-devel-1.41.0-24.el6.i686
--> Processing Dependency: libboost_date_time-mt.so.5 for package: boost-devel-1.41.0-24.el6.i686
---> Package boost-graph-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: mpich2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-mpich2-python.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-python.i686 0:1.41.0-24.el6 will be installed
---> Package boost-serialization.i686 0:1.41.0-24.el6 will be installed
---> Package mpich2-devel.i686 0:1.2.1-2.3.el6 will be installed
--> Processing Dependency: mpich2 = 1.2.1-2.3.el6 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichf90.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libfmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package boost.i686 0:1.41.0-24.el6 will be installed
---> Package boost-date-time.i686 0:1.41.0-24.el6 will be installed
---> Package boost-filesystem.i686 0:1.41.0-24.el6 will be installed
---> Package boost-graph.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: libicuuc.so.42 for package: boost-graph-1.41.0-24.el6.i686
--> Processing Dependency: libicui18n.so.42 for package: boost-graph-1.41.0-24.el6.i686
---> Package boost-graph-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-iostreams.i686 0:1.41.0-24.el6 will be installed
---> Package boost-math.i686 0:1.41.0-24.el6 will be installed
---> Package boost-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: mpich2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-mpich2-python.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-program-options.i686 0:1.41.0-24.el6 will be installed
---> Package boost-regex.i686 0:1.41.0-24.el6 will be installed
---> Package boost-signals.i686 0:1.41.0-24.el6 will be installed
---> Package boost-system.i686 0:1.41.0-24.el6 will be installed
---> Package boost-test.i686 0:1.41.0-24.el6 will be installed
---> Package boost-thread.i686 0:1.41.0-24.el6 will be installed
---> Package boost-wave.i686 0:1.41.0-24.el6 will be installed
---> Package mpich2-devel.i686 0:1.2.1-2.3.el6 will be installed
--> Processing Dependency: mpich2 = 1.2.1-2.3.el6 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichf90.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libfmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package boost-graph-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-graph-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-mpich2.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: mpich2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package boost-mpich2-python.i686 0:1.41.0-24.el6 will be installed
--> Processing Dependency: libmpichcxx.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: boost-mpich2-python-1.41.0-24.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
---> Package libicu.i686 0:4.2.1-9.1.el6_2 will be installed
---> Package mpich2-devel.i686 0:1.2.1-2.3.el6 will be installed
--> Processing Dependency: mpich2 = 1.2.1-2.3.el6 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichf90.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpichcxx.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
--> Processing Dependency: libfmpich.so.1.2 for package: mpich2-devel-1.2.1-2.3.el6.i686
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements

Packages skipped because of dependency problems:
    boost-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-date-time-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-devel-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-filesystem-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-graph-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-graph-mpich2-1.41.0-24.el6.i686 from rhel-6-workstation-optional-beta-rpms
    boost-iostreams-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-math-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-mpich2-1.41.0-24.el6.i686 from rhel-6-workstation-optional-beta-rpms
    boost-mpich2-devel-1.41.0-24.el6.i686 from rhel-6-workstation-optional-beta-rpms
    boost-mpich2-python-1.41.0-24.el6.i686 from rhel-6-workstation-optional-beta-rpms
    boost-program-options-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-python-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-regex-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-serialization-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-signals-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-system-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-test-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-thread-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    boost-wave-1.41.0-24.el6.i686 from rhel-6-workstation-beta-rpms
    libicu-4.2.1-9.1.el6_2.i686 from rhel-6-workstation-beta-rpms
    mpich2-devel-1.2.1-2.3.el6.i686 from rhel-6-workstation-optional-beta-rpms


Expected results:

Install pkgs above successfully.
Additional info:

Even below command still have dependency issu.
yum install -y --skip-broken mpich2-devel boost-mpich2-devel boost-mpich2 boost-mpich2-python boost-graph-mpich2 --disablerepo=* --enablerepo=*-beta-*

Comment 2 haiwang 2014-08-15 12:15:08 UTC
the same situation with workstation x86-64 htb.

Comment 4 haiwang 2014-08-18 08:20:49 UTC
Oops,this bug is opened before bug 1130083,it's also ok to close this one to avoid the log duplicates, I'll verified workstation related platform once bug 1130083 is fixed.

Thanks
Haibo


Note You need to log in before you can comment on or make changes to this bug.