Bug 1130012 - BPMN2 process definition modelled in Web Designer disorders node layout in Swim Lane while opened in JBDS BPMN2 Diagram Editor
Summary: BPMN2 process definition modelled in Web Designer disorders node layout in Sw...
Keywords:
Status: CLOSED DUPLICATE of bug 1062233
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Designer
Version: 6.0.2
Hardware: All
OS: All
high
high
Target Milestone: ---
: ---
Assignee: Tihomir Surdilovic
QA Contact: Sona Mala
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 07:37 UTC by Musharraf Hussain
Modified: 2018-12-06 17:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-18 09:09:08 UTC
Type: Bug


Attachments (Terms of Use)
swimlaneProcess.bpmn2 (7.38 KB, text/plain)
2014-08-14 07:39 UTC, Musharraf Hussain
no flags Details
WebDesigner_layout_perfect.png (64.72 KB, image/png)
2014-08-14 08:21 UTC, Musharraf Hussain
no flags Details
JBDS_layout_broken.png (79.94 KB, image/png)
2014-08-14 08:21 UTC, Musharraf Hussain
no flags Details
SwimLaneIssueSimpleTask.bpmn2 (7.35 KB, text/plain)
2014-08-14 08:22 UTC, Musharraf Hussain
no flags Details

Description Musharraf Hussain 2014-08-14 07:37:14 UTC
Description of problem:
- It has been observed by users while they try to open a BPMN2 process definition (which was originally modelled in Web Designer) in JBDS BPMN2 Diagram Editor , it disorders layout of nodes in Swim Lane. The attached simple BPMN2 process "swimlaneProcess.bpmn2" contains a "Start Node -> Service Task -> End Node" can be imported in the JBDS projects to reproduce the issue. It appears that the round tripping of such type of process definition between the Web Designer and the JBDS Editor is causing such issues in presence of Swim Lanes as seen in this Bugzilla [1] too.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1112456

Version-Release number of selected component (if applicable):
- BPMS 6.0.2
- JBDS 7.1.1

How reproducible:
- Always with the attached "swimlaneProcess.bpmn2" process
Steps to Reproduce:
1. Import the attached "swimlaneProcess.bpmn2" process in JBDS project
2. Open it using BPMN2 Diagram Editor
3. You should see the layout is messed up
4. Try to open the same process definition in Web Designer and there it should at least open and visible properly.

Actual results:
- The process definition layout is broken.

Expected results:
- BPMN2 process layout should be properly visible in BPMN2 Diagram Editor of JBDS

Additional info:
- Nothing

Comment 1 Musharraf Hussain 2014-08-14 07:39:09 UTC
Created attachment 926689 [details]
swimlaneProcess.bpmn2

swimlaneProcess.bpmn2

Comment 4 Musharraf Hussain 2014-08-14 08:20:29 UTC
Hello,

I have just tried to modify the previous example by replacing the Service Task with a simple Script Task. I have attached a new "SwimLaneIssueSimpleTask.bpmn2" process definition which contains a "Start -> Script Task -> End" process flow and enclosed them in a Swim Lane . Even while verifying the process definition in Web Designer it doesn't complain any issue (seen in the attached "WebDesigner_layout_perfect.png" image) , but when I try to import the same in JBDS and open it there it breaks the layout (shown in attached "JBDS_layout_broken.png" image) .

I hope this reproducer should help troubleshoot the issue.


Regards,
Musharraf Hussain

Comment 5 Musharraf Hussain 2014-08-14 08:21:19 UTC
Created attachment 926700 [details]
WebDesigner_layout_perfect.png

WebDesigner_layout_perfect.png

Comment 6 Musharraf Hussain 2014-08-14 08:21:53 UTC
Created attachment 926701 [details]
JBDS_layout_broken.png

JBDS_layout_broken.png

Comment 7 Musharraf Hussain 2014-08-14 08:22:32 UTC
Created attachment 926703 [details]
SwimLaneIssueSimpleTask.bpmn2

SwimLaneIssueSimpleTask.bpmn2

Comment 8 Musharraf Hussain 2014-08-14 09:13:57 UTC
Comment on attachment 926689 [details]
swimlaneProcess.bpmn2

no longer required

Comment 9 Kris Verlaenen 2014-08-18 09:09:08 UTC

*** This bug has been marked as a duplicate of bug 1062233 ***


Note You need to log in before you can comment on or make changes to this bug.