Bug 1130014 - test case 033 and 034 of qemu-iotests fail for vmdk
Summary: test case 033 and 034 of qemu-iotests fail for vmdk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 07:48 UTC by Sibiao Luo
Modified: 2015-07-22 06:06 UTC (History)
13 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.474.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:06:50 UTC


Attachments (Terms of Use)
qemu-iotests-results-for-vmdk.txt (7.26 KB, text/plain)
2014-08-14 07:49 UTC, Sibiao Luo
no flags Details
the full results of testing (283.79 KB, text/plain)
2015-04-30 09:34 UTC, Lin Chen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1275 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2015-07-20 17:49:16 UTC

Comment 1 Sibiao Luo 2014-08-14 07:49:17 UTC
Created attachment 926692 [details]
qemu-iotests-results-for-vmdk.txt

Comment 2 Jeff Nelson 2015-04-29 18:36:06 UTC
Fix included in qemu-kvm-0.12.1.2-2.471.el6

Comment 4 Lin Chen 2015-04-30 09:30:37 UTC
1.QE reproduced the bug on the following environment:
  kernel:  2.6.32-491.el6.x86_64           
  qemu:    qemu-img-rhev-0.12.1.2-2.455.el6.x86_64
           qemu-kvm-rhev-0.12.1.2-2.455.el6.x86_64


2.then retested it on the fixed version:
  kernel:  2.6.32-491.el6.x86_64 
  qemu:    qemu-kvm-0.12.1.2-2.471.el6.x86_64
           qemu-img-0.12.1.2-2.471.el6.x86_64
but got results as following:
Not run: 007 013 014 015 016 022 023 024 025 026 028 029 030 031 035 038 040 041 042 043 044 048 049 054 060 067 068 073 074 079 080 081 083 084 085 086 088 092 095 107 108 114
Failures: 001 002 003 004 005 008 009 010 011 012 017 018 019 020 027 032 033 034 037 052
Failed 20 of 22 tests

So the fixed version didn't resolve the issue.
additionally,attached is the full results of testing.

Comment 5 Lin Chen 2015-04-30 09:34:40 UTC
Created attachment 1020485 [details]
the full results of testing

Comment 6 Qunfang Zhang 2015-05-06 02:55:35 UTC
Re-assign according to comment 4, fix us if something is wrong.

Comment 7 Fam Zheng 2015-05-06 05:24:56 UTC
The issue was introduced in the recent aio series. Backporting this fix from upstream:

    block: avoid useless checks on acb->bh

    Coverity is confused by this "if" and reports leaks on acb->bh.
    The bottom half is always deleted before releasing the AIOCB,
    in either bdrv_aio_cancel_em or bdrv_aio_bh_cb.

    Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
    Signed-off-by: Kevin Wolf <kwolf@redhat.com>

Comment 8 Jeff Nelson 2015-05-06 18:05:40 UTC
Fix included in qemu-kvm-0.12.1.2-2.474.el6

Comment 10 Qunfang Zhang 2015-05-11 06:32:35 UTC
Verified pass on qemu-kvm-rhev-0.12.1.2-2.475.el6.x86_64.

[root@localhost qemu-iotests]# ./check -vmdk
QEMU          -- /usr/libexec/qemu-kvm
QEMU_IMG      -- /usr/bin/qemu-img
QEMU_IO       -- /usr/bin/qemu-io 
QEMU_NBD      -- 
IMGFMT        -- vmdk
IMGPROTO      -- file
PLATFORM      -- Linux/x86_64 localhost 2.6.32-554.el6.x86_64
SOCKET_SCM_HELPER -- 

001        
002        
003        
004        
005        
007         [not run] not suitable for this image format: vmdk
008        
009        
010        
011        
012        
013         [not run] not suitable for this image format: vmdk
014         [not run] not suitable for this image format: vmdk
015         [not run] not suitable for this image format: vmdk
016         [not run] not suitable for this image format: vmdk
017        
018        
019        
020        
021 0s ...
022         [not run] not suitable for this image format: vmdk
023         [not run] not suitable for this image format: vmdk
024         [not run] not suitable for this image format: vmdk
025         [not run] not suitable for this image format: vmdk
026         [not run] not suitable for this image format: vmdk
027        
028         [not run] not suitable for this image format: vmdk
029         [not run] not suitable for this image format: vmdk
030         [not run] not suitable for this image format: vmdk
031         [not run] not suitable for this image format: vmdk
032        
033        
034        
035         [not run] not suitable for this image format: vmdk
037        
038         [not run] not suitable for this image format: vmdk
040         [not run] not suitable for this image format: vmdk
041         [not run] not suitable for this image format: vmdk
042         [not run] not suitable for this image format: vmdk
043         [not run] not suitable for this image format: vmdk
044         [not run] not suitable for this image format: vmdk
048         [not run] not suitable for this image format: vmdk
049         [not run] not suitable for this image format: vmdk
052        
054         [not run] not suitable for this image format: vmdk
060         [not run] not suitable for this image format: vmdk
067         [not run] not suitable for this image format: vmdk
068         [not run] not suitable for this image format: vmdk
069 0s ...
073         [not run] not suitable for this image format: vmdk
074         [not run] not suitable for this image format: vmdk
079         [not run] not suitable for this image format: vmdk
080         [not run] not suitable for this image format: vmdk
081         [not run] not suitable for this image format: vmdk
083         [not run] not suitable for this image protocol: file
084         [not run] not suitable for this image format: vmdk
085         [not run] not suitable for this image format: vmdk
086         [not run] not suitable for this image format: vmdk
088         [not run] not suitable for this image format: vmdk
092         [not run] not suitable for this image format: vmdk
095         [not run] not suitable for this image format: vmdk
107         [not run] not suitable for this image format: vmdk
108         [not run] not suitable for this image format: vmdk
114         [not run] not suitable for this image format: vmdk
Not run: 007 013 014 015 016 022 023 024 025 026 028 029 030 031 035 038 040 041 042 043 044 048 049 054 060 067 068 073 074 079 080 081 083 084 085 086 088 092 095 107 108 114
Passed all 22 tests

Comment 13 errata-xmlrpc 2015-07-22 06:06:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1275.html


Note You need to log in before you can comment on or make changes to this bug.