Bug 1130016 - [RFE] Hosted engine host information is missing from the REST API
Summary: [RFE] Hosted engine host information is missing from the REST API
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Martin Sivák
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 07:52 UTC by Martin Sivák
Modified: 2019-04-28 09:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-06 12:27:15 UTC
oVirt Team: SLA
ylavi: ovirt-future?
rule-engine: planning_ack?
msivak: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Martin Sivák 2014-08-14 07:52:21 UTC
Description of problem:

When a host is part of a hosted engine environment, the score and hosted engine status should be reported through /api/hosts and /api/host/<uuid> REST resources.

This is needed for external scheduler and ovirt-optimizer rules.

Version-Release number of selected component (if applicable):

3.4, 3.5

How reproducible:

Just try to use REST to retrieve the hosted engine score of a host

Comment 1 Doron Fediuck 2015-06-07 08:58:07 UTC
This seems to be more a bug than an RFE.
Targeting for 3.6.0.

Comment 2 Martin Sivák 2015-12-01 09:27:26 UTC
We need this since more and more deployments are using hosted engine and the score information is used in scheduling. Optimizer should match the internal scheduler as close as possible and it currently does not have the necessary information to do so.

Comment 3 Red Hat Bugzilla Rules Engine 2015-12-01 09:27:28 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 4 Simone Tiraboschi 2018-06-06 12:27:15 UTC
Now hosted-engine info are correctly reported on REST API: http://ovirt.github.io/ovirt-engine-api-model/4.2/#types/hosted_engine

Please reopen if not enough.


Note You need to log in before you can comment on or make changes to this bug.