Bug 1130030 - FreeSpaceCriticalLowInGB variable takes negative values
Summary: FreeSpaceCriticalLowInGB variable takes negative values
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-config
Version: 3.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Allon Mureinik
QA Contact: Ori Gofen
URL:
Whiteboard: storage
: 1130026 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 08:16 UTC by Ori Gofen
Modified: 2016-02-10 19:44 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:45:09 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31511 master MERGED core: Validate FreeSpaceCriticalLowInGB conf value Never
oVirt gerrit 31527 ovirt-engine-3.5 MERGED core: Validate FreeSpaceCriticalLowInGB conf value Never

Description Ori Gofen 2014-08-14 08:16:53 UTC
Description of problem:
FreeSpaceCriticalLowInGB is a flag that warns the user when a domain has reached threshold level and prevent from creating new disks,however, this variable needs to unsigned because we do not want it to take negative values.

this is the default flag state:

root@ovirt-gofen-1 ~ # engine-config -g FreeSpaceCriticalLowInGB      
FreeSpaceCriticalLowInGB: 5 version: general

now I'm forcing FreeSpaceCriticalLow to be -3:

root@ovirt-gofen-1 ~ # engine-config -s FreeSpaceCriticalLowInGB=-3

check that the value is kept:

root@ovirt-gofen-1 ~ # engine-config -g FreeSpaceCriticalLowInGB   
FreeSpaceCriticalLowInGB: -3 version: general

Version-Release number of selected component (if applicable):
rc1

How reproducible:
100%

Steps to Reproduce:
1.engine-config -s FreeSpaceCriticalLowInGB=NEGATIVE_VALUE
2.restart engine

Actual results:
domain's has invalid free space threshold

Expected results:
domain's free space threshold > 0

Additional info:

Comment 1 Allon Mureinik 2014-08-14 12:08:16 UTC
This is just a bad value, it has NOTHING to do with data corruption.

Comment 2 Allon Mureinik 2014-08-14 12:19:53 UTC
We could probably add some validation on the conf value, but need to make sure the proper infra is in place.

Comment 3 Aharon Canan 2014-08-14 12:54:43 UTC
*** Bug 1130026 has been marked as a duplicate of this bug. ***

Comment 4 Ori Gofen 2014-08-17 09:16:53 UTC
This bug can cause data corruption,BZ #1130740 (In reply to Allon Mureinik from comment #1)
> This is just a bad value, it has NOTHING to do with data corruption.

Comment 5 Allon Mureinik 2014-08-17 12:32:44 UTC
(In reply to Ori from comment #4)
> This bug can cause data corruption,BZ #1130740 (In reply to Allon Mureinik
> from comment #1)
> > This is just a bad value, it has NOTHING to do with data corruption.
This one has NOTHING to do with data corruption either.

Comment 7 Ori Gofen 2014-08-26 11:18:24 UTC
verified on rc1.1

Comment 8 Sandro Bonazzola 2014-10-17 12:45:09 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.