Bug 1130046 - test case 084 of qemu-iotests fail for vdi
Summary: test case 084 of qemu-iotests fail for vdi
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jeff Cody
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 08:38 UTC by Sibiao Luo
Modified: 2015-07-22 06:07 UTC (History)
15 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.478.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:07:02 UTC


Attachments (Terms of Use)
qemu-iotests-results-for-vdi.txt (5.24 KB, text/plain)
2014-08-14 08:39 UTC, Sibiao Luo
no flags Details
qemu-iotests result. (8.12 KB, text/plain)
2015-05-25 05:58 UTC, mazhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1275 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2015-07-20 17:49:16 UTC

Comment 1 Sibiao Luo 2014-08-14 08:39:19 UTC
Created attachment 926705 [details]
qemu-iotests-results-for-vdi.txt

Comment 2 Jeff Nelson 2015-04-09 03:56:38 UTC
Fix included in qemu-kvm-0.12.1.2-2.465.el6

Comment 3 mazhang 2015-04-10 08:35:07 UTC
Reproduce this bug on qemu-kvm-0.12.1.2-2.428.el6.x86_64.

Steps:
1. Download qemu-iotests.
# git clone git://git.app.eng.bos.redhat.com/virt/rhel6/qemu-kvm.git

2. Run vpc test.

Result:
054         [not run] not suitable for this image format: vdi
060         [not run] not suitable for this image format: vdi
067         [not run] not suitable for this image format: vdi
068         [not run] not suitable for this image format: vdi
069         [not run] not suitable for this image format: vdi
073         [not run] not suitable for this image format: vdi
074         [not run] not suitable for this image format: vdi
079         [not run] not suitable for this image format: vdi
080         [not run] not suitable for this image format: vdi
081         [not run] not suitable for this image format: vdi
083         [not run] not suitable for this image protocol: file
084 2s ...
085         [not run] not suitable for this image format: vdi
086         [not run] not suitable for this image format: vdi
088 0s ... [not run] not suitable for this image format: vdi
092         [not run] not suitable for this image format: vdi
095         [not run] not suitable for this image format: vdi
Not run: 007 013 014 015 016 017 018 019 020 022 023 024 025 026 027 028 029 030 031 034 035 037 038 040 041 042 043 044 048 049 054 060 067 068 069 073 074 079 080 081 083 085 086 088 092 095
Failures: 001 002 003 004 005 008 009 010 011 012 021 032 033 052
Failed 14 of 15 tests


Verify this bug on qemu-kvm-0.12.1.2-2.465.el6.x86_64.

Result:
Not run: 007 013 014 015 016 017 018 019 020 022 023 024 025 026 027 028 029 030 031 034 035 037 038 040 041 042 043 044 048 049 054 060 067 068 069 073 074 079 080 081 083 085 086 088 092 095
Passed all 15 tests

So this bug has been fixed.

Comment 6 mazhang 2015-05-25 05:57:26 UTC
Hit this problem on qemu-kvm-rhev-0.12.1.2-2.475.el6.x86_64, so reopen this bug.

Comment 7 mazhang 2015-05-25 05:58:42 UTC
Created attachment 1029349 [details]
qemu-iotests result.

Comment 8 Qunfang Zhang 2015-05-25 06:21:50 UTC
Hi, Jeff

Could you help have a look at this bug? It seems some regression is introduced. 

Thanks,
Qunfang

Comment 14 Jeff Nelson 2015-06-03 17:17:47 UTC
Fix included in qemu-kvm-0.12.1.2-2.478.el6

Comment 15 Qunfang Zhang 2015-06-04 06:07:05 UTC
Reproduced this issue on qemu-kvm-0.12.1.2-2.477.el6, some test failed. 

Verified this bug on latest qemu-kvm-0.12.1.2-2.478.el6, all the tests passed. 



[root@localhost qemu-iotests]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.478.el6.x86_64

[root@localhost qemu-iotests]# ./check -vdi
QEMU          -- /usr/libexec/qemu-kvm
QEMU_IMG      -- /usr/bin/qemu-img
QEMU_IO       -- /usr/bin/qemu-io 
QEMU_NBD      -- 
IMGFMT        -- vdi
IMGPROTO      -- file
PLATFORM      -- Linux/x86_64 localhost 2.6.32-563.el6.x86_64
SOCKET_SCM_HELPER -- 

001 2s ...
002 2s ...
003 2s ...
004 0s ...
005 1s ...
007         [not run] not suitable for this image format: vdi
008 1s ...
009 0s ...
010 0s ...
011 0s ...
012 1s ...
013         [not run] not suitable for this image format: vdi
014         [not run] not suitable for this image format: vdi
015         [not run] not suitable for this image format: vdi
016         [not run] not suitable for this image format: vdi
017         [not run] not suitable for this image format: vdi
018         [not run] not suitable for this image format: vdi
019         [not run] not suitable for this image format: vdi
020         [not run] not suitable for this image format: vdi
021 1s ...
022         [not run] not suitable for this image format: vdi
023         [not run] not suitable for this image format: vdi
024         [not run] not suitable for this image format: vdi
025         [not run] not suitable for this image format: vdi
026         [not run] not suitable for this image format: vdi
027         [not run] not suitable for this image format: vdi
028         [not run] not suitable for this image format: vdi
029         [not run] not suitable for this image format: vdi
030         [not run] not suitable for this image format: vdi
031         [not run] not suitable for this image format: vdi
032 0s ...
033 0s ...
034         [not run] not suitable for this image format: vdi
035         [not run] not suitable for this image format: vdi
037         [not run] not suitable for this image format: vdi
038         [not run] not suitable for this image format: vdi
040         [not run] not suitable for this image format: vdi
041         [not run] not suitable for this image format: vdi
042         [not run] not suitable for this image format: vdi
043         [not run] not suitable for this image format: vdi
044         [not run] not suitable for this image format: vdi
048         [not run] not suitable for this image format: vdi
049         [not run] not suitable for this image format: vdi
052 3s ...
054         [not run] not suitable for this image format: vdi
060         [not run] not suitable for this image format: vdi
067         [not run] not suitable for this image format: vdi
068         [not run] not suitable for this image format: vdi
069         [not run] not suitable for this image format: vdi
073         [not run] not suitable for this image format: vdi
074         [not run] not suitable for this image format: vdi
079         [not run] not suitable for this image format: vdi
080         [not run] not suitable for this image format: vdi
081         [not run] not suitable for this image format: vdi
083         [not run] not suitable for this image protocol: file
084 2s ...
085         [not run] not suitable for this image format: vdi
086         [not run] not suitable for this image format: vdi
088         [not run] not suitable for this image format: vdi
092         [not run] not suitable for this image format: vdi
095         [not run] not suitable for this image format: vdi
107         [not run] not suitable for this image format: vdi
108         [not run] not suitable for this image format: vdi
114         [not run] not suitable for this image format: vdi
Not run: 007 013 014 015 016 017 018 019 020 022 023 024 025 026 027 028 029 030 031 034 035 037 038 040 041 042 043 044 048 049 054 060 067 068 069 073 074 079 080 081 083 085 086 088 092 095 107 108 114
Passed all 15 tests

Based above, I will set the status to VERIFIED.

Comment 17 errata-xmlrpc 2015-07-22 06:07:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1275.html


Note You need to log in before you can comment on or make changes to this bug.