Bug 1130115 - Dependencies error: python-magic-5.04-15.el6.x86_64 requires: file = 5.04-15.el6
Summary: Dependencies error: python-magic-5.04-15.el6.x86_64 requires: file = 5.04-15.el6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Kaluža
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 11:22 UTC by Jindrich Luza
Modified: 2014-08-15 08:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 08:00:41 UTC


Attachments (Terms of Use)

Description Jindrich Luza 2014-08-14 11:22:37 UTC
$ yum install rpmlint

Produce:
-- STDOUT --
Loaded plugins: product-id, security, subscription-manager
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package rpmlint.noarch 0:0.94-3.1.el6 will be installed
--> Processing Dependency: python-magic for package: rpmlint-0.94-3.1.el6.noarch
--> Processing Dependency: python-enchant for package: rpmlint-0.94-3.1.el6.noarch
--> Running transaction check
---> Package python-enchant.x86_64 0:1.3.1-5.2.el6 will be installed
--> Processing Dependency: libenchant.so.1()(64bit) for package: python-enchant-1.3.1-5.2.el6.x86_64
---> Package python-magic.x86_64 0:5.04-15.el6 will be installed
--> Processing Dependency: file = 5.04-15.el6 for package: python-magic-5.04-15.el6.x86_64
--> Running transaction check
---> Package enchant.x86_64 1:1.5.0-4.el6 will be installed
---> Package python-magic.x86_64 0:5.04-15.el6 will be installed
--> Processing Dependency: file = 5.04-15.el6 for package: python-magic-5.04-15.el6.x86_64
--> Finished Dependency Resolution
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

-- STDERR --
Error: Package: python-magic-5.04-15.el6.x86_64 (rhel-6-server-rpms)
           Requires: file = 5.04-15.el6
           Installed: file-5.04-21.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201408132211.x86_64/6.6)
               file = 5.04-21.el6
           Available: file-5.04-5.el6.x86_64 (rhel-6-server-rpms)
               file = 5.04-5.el6
           Available: file-5.04-6.el6.x86_64 (rhel-6-server-rpms)
               file = 5.04-6.el6
           Available: file-5.04-9.el6.x86_64 (rhel-6-server-rpms)
               file = 5.04-9.el6
           Available: file-5.04-11.el6.x86_64 (rhel-6-server-rpms)
               file = 5.04-11.el6
           Available: file-5.04-13.el6.x86_64 (rhel-6-server-rpms)
               file = 5.04-13.el6
           Available: file-5.04-15.el6.x86_64 (rhel-6-server-rpms)
               file = 5.04-15.el6

Comment 3 Jindrich Luza 2014-08-15 08:00:41 UTC
So I found out where was the problem. Instalation image was build with nightly repositories and after instalation, file package was instaled from theese repositories. So it has release .21. After instalation I started using rhel-6 repositories and that was the problem, because I didn't realize it was rhel-6.5 repositories. So file there and python-magic is older than in nightly. After switch to rhel-6.6 beta repositories python-magic release is same as file release - .20. So everything should be probably fine.


Note You need to log in before you can comment on or make changes to this bug.