Bug 113014 - dvb-ttpci.ko from kernel-unsupported-modules has unresolved symbols
dvb-ttpci.ko from kernel-unsupported-modules has unresolved symbols
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-07 08:45 EST by Ralf Ertzinger
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-19 04:49:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2004-01-07 08:45:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When installing kernel-unsupported-modules-2.6.0-1.118, depmod
complains about unresolved symbols:

WARNING:
/lib/modules/2.6.0-1.118/unsupported/drivers/media/dvb/ttpci/dvb-ttpci.ko
needs unknown symbol __floatsidf
WARNING:
/lib/modules/2.6.0-1.118/unsupported/drivers/media/dvb/ttpci/dvb-ttpci.ko
needs unknown symbol __ltdf2
WARNING:
/lib/modules/2.6.0-1.118/unsupported/drivers/media/dvb/ttpci/dvb-ttpci.ko
needs unknown symbol __adddf3


This module ought to be disabled, since it would not work anyways.

Version-Release number of selected component (if applicable):
kernel-2.6.0-1.118

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-unsupported-modules-2.6.0-1.118
2. Run depmod
3.
    

Actual Results:  Unresolved symbols

Expected Results:  No errors

Additional info:
Comment 1 Dave Jones 2004-01-07 08:52:13 EST
Ick, another module using floating point maths.
This isn't allowed in the kernel.
Comment 2 Arjan van de Ven 2004-01-19 04:49:33 EST
fixed 

Note You need to log in before you can comment on or make changes to this bug.