Bug 1130140 - Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as on Centos 6.5
Summary: Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 12:19 UTC by Netbulae
Modified: 2015-01-16 10:10 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-10 12:09:55 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Netbulae 2014-08-14 12:19:55 UTC
Description of problem:

Centos 6.5 host with ovirt 3.5 all in one install:

engine-setup

[ INFO  ] Stage: Misc configuration
[ ERROR ] Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as
[ INFO  ] Yum Performing yum transaction rollback



Version-Release number of selected component (if applicable):
3.5rc1 All in one setup on Centos 6.5

Workaround:

engine-setup --jboss-home=/usr/share/ovirt-engine-jboss-as

Additional info:

ovirt-engine-sdk-python-3.5.0.4-1.20140728.gitec31051.el6.noarch
ovirt-host-deploy-1.3.0-0.0.master.20140804175631.git89155f8.el6.noarch
ovirt-iso-uploader-3.5.0-0.1.master.el6.noarch
ovirt-engine-setup-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-host-deploy-offline-1.3.0-0.0.master.20140804175631.git89155f8.el6.x86_64
ovirt-host-deploy-java-1.3.0-0.0.master.20140804175631.git89155f8.el6.noarch
ovirt-engine-tools-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-base-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-cli-3.5.0.3-1.20140718.git0d72c6e.el6.noarch
ovirt-engine-jboss-as-7.1.1-1.el6.x86_64
ovirt-engine-backend-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-restapi-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-userportal-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-websocket-proxy-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-dbscripts-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-release35-001-0.5.rc2.noarch
ovirt-image-uploader-3.5.0-0.1.master.el6.noarch
ovirt-engine-lib-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-extensions-api-impl-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-plugin-allinone-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

Comment 1 Simone Tiraboschi 2014-08-20 13:37:20 UTC
(In reply to Netbulae from comment #0)
> Description of problem:
> 
> Centos 6.5 host with ovirt 3.5 all in one install:
> 
> engine-setup
> 
> [ INFO  ] Stage: Misc configuration
> [ ERROR ] Failed to execute stage 'Misc configuration': Cannot find Jboss at
> /usr/share/jboss-as
> [ INFO  ] Yum Performing yum transaction rollback
> 
> 
> 
> Version-Release number of selected component (if applicable):
> 3.5rc1 All in one setup on Centos 6.5
> 

Hi Netbulae,
I tried to reproduce on a fresh install of 3.5 rc1 on Centos 6.5 and it works correctly finding jboss under /usr/share/ovirt-engine-jboss-as

Are you able to reproduce it or can you provide more details about that?

Comment 2 Netbulae 2014-08-20 13:47:21 UTC
Just tried it again, do we have the same rpm's?

[ INFO  ] Stage: Transaction setup
[ INFO  ] Stopping engine service
[ INFO  ] Stopping ovirt-fence-kdump-listener service
[ INFO  ] Stopping websocket-proxy service
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ ERROR ] Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140820154514-mk4g4m.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20140820154530-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

[root@test log]# rpm -qa|grep ovirt
ovirt-engine-jboss-as-7.1.1-1.el6.x86_64
ovirt-engine-backend-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-lib-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-websocket-proxy-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-host-deploy-1.3.0-0.0.master.20140804175631.git89155f8.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-iso-uploader-3.5.0-0.1.master.el6.noarch
ovirt-host-deploy-offline-1.3.0-0.0.master.20140804175631.git89155f8.el6.x86_64
ovirt-engine-tools-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-dbscripts-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-release35-001-0.5.rc2.noarch
ovirt-engine-setup-base-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-host-deploy-java-1.3.0-0.0.master.20140804175631.git89155f8.el6.noarch
ovirt-engine-cli-3.5.0.3-1.20140718.git0d72c6e.el6.noarch
ovirt-engine-extensions-api-impl-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-userportal-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-plugin-allinone-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-sdk-python-3.5.0.4-1.20140728.gitec31051.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-setup-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
ovirt-image-uploader-3.5.0-0.1.master.el6.noarch
ovirt-engine-restapi-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

Comment 3 Simone Tiraboschi 2014-08-29 11:47:31 UTC
I don't have the exact list cause I cleaned that VM but I tried again with 3.5 RC1.1 and it seams to work as expected.

My RPMs are:
ovirt-engine-setup-base-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-restapi-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-guest-agent-1.0.10-1.el6.noarch
ovirt-host-deploy-1.3.0-0.0.master.20140820115650.git89155f8.el6.noarch
ovirt-engine-sdk-python-3.5.0.5-1.20140820.gitc47c189.el6.noarch
ovirt-release-el6-10.0.1-3.noarch
ovirt-release35-001-0.4.rc1.noarch
ovirt-iso-uploader-3.5.0-0.1.master.20140812133501.gita818d93.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-host-deploy-java-1.3.0-0.0.master.20140820115650.git89155f8.el6.noarch
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-backend-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-dbscripts-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-plugin-allinone-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-cli-3.5.0.4-1.20140820.git374a657.el6.noarch
ovirt-engine-jboss-as-7.1.1-1.el6.x86_64
ovirt-engine-lib-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-websocket-proxy-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-tools-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-userportal-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-host-deploy-offline-1.3.0-0.0.master.20140820115650.git89155f8.el6.x86_64
ovirt-image-uploader-3.5.0-0.1.master.20140811110806.git321a491.el6.noarch
ovirt-engine-extensions-api-impl-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch


The required modification has been merged the 23th of May so it should be also in your RPMS. http://gerrit.ovirt.org/#/c/28064/

Can you please check the content of:
/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf

Comment 4 Netbulae 2014-09-05 10:05:02 UTC
I have the same RPM's but the config still points to the old path. This can be because I installed/upgraded multiple times along the way.

cat /etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf
[environment:default]
OVESETUP_CONFIG/jbossHome=str:/usr/share/ovirt-engine-jboss-as

But I did a yum remove and it was gone:

cat /etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf
cat: /etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf: No such file or directory

Then I reinstalled the rpm's and it's still the old path and setup still fails:

cat /etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf
[environment:default]
OVESETUP_CONFIG/jbossHome=str:/usr/share/ovirt-engine-jboss-as

My rpm list:
ovirt-engine-sdk-python-3.5.0.5-1.20140820.gitc47c189.el6.noarch
ovirt-engine-jboss-as-7.1.1-1.el6.x86_64
ovirt-engine-setup-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-extensions-api-impl-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-dbscripts-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-image-uploader-3.5.0-0.1.master.20140811110806.git321a491.el6.noarch
ovirt-host-deploy-java-1.3.0-0.0.master.20140820115650.git89155f8.el6.noarch
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-restapi-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-base-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-iso-uploader-3.5.0-0.1.master.20140812133501.gita818d93.el6.noarch
ovirt-host-deploy-1.3.0-0.0.master.20140820115650.git89155f8.el6.noarch
ovirt-engine-tools-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-websocket-proxy-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-backend-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-lib-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch
ovirt-engine-cli-3.5.0.4-1.20140820.git374a657.el6.noarch
ovirt-engine-userportal-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch

Comment 5 Netbulae 2014-09-05 10:09:59 UTC
Sorry I was looking crooked, the path in "/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf" is and was correct but it appears to be ignored...

engine-setup --config=/var/lib/ovirt-engine/setup/answers/20140818114004-setup.conf

[ ERROR ] Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as

I checked the answers file but it's not getting that path from there.

Comment 6 Netbulae 2014-09-05 10:19:31 UTC
Weird, without the answers file setup works without the error. 

But the answer file doesn't have a jboss parameter at all:

# action=setup
[environment:default]
OVESETUP_DIALOG/confirmSettings=bool:True
OVESETUP_CONFIG/applicationMode=str:virt
OVESETUP_CONFIG/updateFirewall=bool:True
OVESETUP_CONFIG/fqdn=str:xxx.xxxx.xxxx
OVESETUP_CONFIG/storageType=str:posixfs
OVESETUP_CONFIG/adminPassword=str:*********
OVESETUP_CONFIG/firewallManager=str:iptables
OSETUP_RPMDISTRO/requireRollback=none:None
OSETUP_RPMDISTRO/enableUpgrade=none:None
OVESETUP_DB/database=str:engine
OVESETUP_DB/fixDbViolations=none:None
OVESETUP_DB/secured=bool:False
OVESETUP_DB/host=str:localhost
OVESETUP_DB/user=str:engine
OVESETUP_DB/securedHostValidation=bool:False
OVESETUP_DB/password=str:bdbWhm57S7qg41f2hQlKgV
OVESETUP_DB/port=int:5432
OVESETUP_ENGINE_CORE/enable=bool:True
OVESETUP_CORE/engineStop=none:None
OVESETUP_SYSTEM/memCheckEnabled=bool:True
OVESETUP_SYSTEM/nfsConfigEnabled=bool:True
OVESETUP_PKI/organization=str:Netbulae
OVESETUP_CONFIG/isoDomainMountPoint=str:/var/lib/exports/iso
OVESETUP_CONFIG/isoDomainName=str:ISO_DOMAIN
OVESETUP_CONFIG/isoDomainACL=str:xxxx.xxxx.xxx(rw)
OVESETUP_AIO/configure=bool:True
OVESETUP_AIO/storageDomainDir=str:/var/lib/images
OVESETUP_PROVISIONING/postgresProvisioningEnabled=bool:True
OVESETUP_APACHE/configureRootRedirection=bool:True
OVESETUP_APACHE/configureSsl=bool:True
OVESETUP_CONFIG/websocketProxyConfig=bool:True

So I did a fresh install without answer file and there is still no jboss parameter in there. Then I did engine-cleanup and engine-setup with the latest answer file and it fails again.

I think "OVESETUP_CONFIG/jbossHome=str:/usr/share/ovirt-engine-jboss-as" has to be added to the answer file generated by setup to fix this.

Comment 7 Simone Tiraboschi 2014-09-10 12:09:55 UTC
(In reply to Netbulae from comment #5)
> Sorry I was looking crooked, the path in
> "/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf" is and was correct
> but it appears to be ignored...
> 
> engine-setup
> --config=/var/lib/ovirt-engine/setup/answers/20140818114004-setup.conf

(In reply to Netbulae from comment #6)
> I think "OVESETUP_CONFIG/jbossHome=str:/usr/share/ovirt-engine-jboss-as" has
> to be added to the answer file generated by setup to fix this.

The problem is just there: you have to distinct CLI options on engine-setup
    --config=file
        Load configuration files.
    --config-append=file
        Load extra configuration files or answer file.

The first one loads a custom configuration file from a custom location instead of loading the default configuration, the second one instead appends options from an extra configuration file or from an answer file to the default configuration.
Answer file should just be used with --config-append because it's not a complete configuration containing just response to interactive questions for unattended setups.

I'll close this cause I think that the problem is just there, please reopen if it happens also using  --config-append=

Comment 8 Lukas Zapletal 2014-11-10 14:35:02 UTC
I was hitting the very same bug on RHEL 6.6 until I found Simone's explanation. Thank you so much! It's very misleading, I think the --config option should be renamed. After I found it in --help I did not search for anything else because I've thought this is what I want. At least there should be BIG PHAT warning in the help screen that this is most likely what you don't want.

I vote from removing this option from the help screen and documentation so only experienced users or QAs can use that. :-)

Comment 9 Jens D 2015-01-16 10:10:50 UTC
Ran into the same problem on CentOS 6.6 after uninstalling and reinstalling oVirt.
This was the output of engine-setup:

[ ERROR ] Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20150116104457-dmh3y7.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20150116104718-setup.conf'

Got the following error: Failed to execute stage 'Misc configuration': Cannot find Jboss at /usr/share/jboss-as

/usr/share/jboss-as indeed didn't exist but /usr/share/ovirt-engine-jboss-as did.

So as Simone and Netbulae pointed out, I added this line:
OVESETUP_CONFIG/jbossHome=str:/usr/share/ovirt-engine-jboss-as

to the answer file: /var/lib/ovirt-engine/setup/answers/20150116104718-setup.conf
and I reran engine-setup as follows:
# engine-setup --config-append=/var/lib/ovirt-engine/setup/answers/20150116104718-setup.conf

This seemed to work fine :)


Note You need to log in before you can comment on or make changes to this bug.