Bug 1130216 - "Forget your password" shouldn't be in the middle of tabbing between "Login" => "Password" => "Sign in"
Summary: "Forget your password" shouldn't be in the middle of tabbing between "Login" ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 14:48 UTC by Daniel Fisher
Modified: 2015-06-12 13:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-12 02:03:50 UTC


Attachments (Terms of Use)

Description Daniel Fisher 2014-08-14 14:48:45 UTC
When I login to a website, I like to use the tab button to move between elements.

As it stands right now, I 
start on the "Login" input element 
[tab] => "Password" element
[tab] => "Forget your password?" link
[tab] => "Sign in" button

I think that the tab order should be:
start on the "Login" input element 
[tab] => "Password" element
[tab] => "Sign in" button
then (maybe)
[tab] => "Forget your password?" link

Comment 1 Daniel Fisher 2015-06-12 04:34:40 UTC
Why WONTFIX?

Is a new page rolling out sometime in the indeterminate future that won't have this problem?

This can be fixed with some judicious addition of tabindex attributes.

http://webcheatsheet.com/HTML/controll_tab_order.php

Comment 2 Dan McPherson 2015-06-12 13:11:11 UTC
There will be a change in the future along with the rollout of OpenShift v3 in online.  I closed this as a recognition that this bug won't be fixed on the existing v2 codebase.


Note You need to log in before you can comment on or make changes to this bug.