Bug 113025 - SCSI tape problems with 2.6.0
SCSI tape problems with 2.6.0
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-07 10:38 EST by Sammy
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-09 11:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-01-07 10:38:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; X11; , en_US, en)

Description of problem:
I now have a working system with 2.6.0 for everything excpet my SCSI
external tape. Tape is recognized properly during the boot. What is happening
is that whenever I try to write something to the tape it starts the process
correctly but when it tries to write the first file the busy light on tape
starts to flicker rapidly (much faster than when it writes normally) and hangs
that way. I can't even kill the tar process. By the way, this works fine with
the Fedora/rawhide 2.2.4 kernels. My SCSI adapeter is mptfusion. Here is 
the info from /var/log/dmesg:
----------------------------------------------------------------
Fusion MPT base driver 2.05.00.05
Copyright (c) 1999-2003 LSI Logic Corporation
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator}
mptbase: Initiating ioc1 bringup
ioc1: 53C1030: Capabilities={Initiator}
mptbase: 2 MPT adapters found, 2 installed.
Fusion MPT SCSI Host driver 2.05.00.05
scsi0 : ioc0: LSI53C1030, FwRev=01011800h, Ports=1, MaxQ=222, IRQ=16
  Vendor: SONY      Model: SDT-9000          Rev: 0400
  Type:   Sequential-Access                  ANSI SCSI revision: 02
Attached scsi tape st0 at scsi0, channel 0, id 2, lun 0
st0: try direct i/o: yes, max page reachable by HBA 4294967295
Attached scsi generic sg0 at scsi0, channel 0, id 2, lun 0,  type 1
scsi1 : ioc1: LSI53C1030, FwRev=01011800h, Ports=1, MaxQ=222, IRQ=17
  Vendor: SEAGATE   Model: ST336732LW        Rev: 2227
  Type:   Direct-Access                      ANSI SCSI revision: 03
SCSI device sda: 71132959 512-byte hdwr sectors (36420 MB)
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 >
Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
Attached scsi generic sg1 at scsi1, channel 0, id 0, lun 0,  type 0
----------------------------------------------------------------
----------------------------------------------------------------
#cat /proc/scsi
Host: scsi0 Channel: 00 Id: 02 Lun: 00
  Vendor: SONY     Model: SDT-9000         Rev: 0400
  Type:   Sequential-Access                ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: SEAGATE  Model: ST336732LW       Rev: 2227
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: HL-DT-ST Model: CD-RW GCE-8481B  Rev: C102
  Type:   CD-ROM                           ANSI SCSI revision: 02
--------------------------------------------------------------------

Version-Release number of selected component (if applicable):
kernel-smp-2.6.0-1.118

How reproducible:
Always

Steps to Reproduce:
1. Boot system with 2.6.0
2. login as root
3. tar -cvf /dev/tape AnyFile
   (tape is link to nst0, same behavior with st0)
    

Actual Results:  Write process hangs with busy light flickerring rapidly

Expected Results:  Should write to tape

Additional info:
Comment 1 Sammy 2004-01-09 11:56:43 EST
I iterated this with the author of st.c, and after some debugging we 
could not determine the cause. It seems to be some kind of a 
termination problem on the specific mpt fusion adapter. I took 
the easy route and insalled an old qlogic adapter and using that 
fine with the scsi tape. I'll close this case since it looks like a unique 
case. 

Note You need to log in before you can comment on or make changes to this bug.