Bug 1130253 - Tempest fails to provision during packstack installation
Summary: Tempest fails to provision during packstack installation
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Gaël Chamoulaud
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 16:35 UTC by rlopez
Modified: 2014-09-08 05:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-03 20:45:16 UTC


Attachments (Terms of Use)

Description rlopez 2014-08-14 16:35:06 UTC
Description of problem:
Tempest fails to provision using packstack. Installation consists of 1 controller node, and 1 compute node. 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. packstack --gen-answer-file
2. set CONFIG_PROVISION_TEMPEST to y
3. Run packstack --answer-file=<answer-file>

Actual results:
ERROR : Error appeared during Puppet run: 10.19.142.117_provision_tempest.pp
Error: concat(): Requires array to work with at /var/tmp/packstack/e580af1b01594225bc4f3257542b0fed/manifests/10.19.142.117_provision_tempest.pp:173 on node rl-controller.cloud.lab.eng.bos.redhat.com
You will find full trace in log /var/tmp/packstack/20140814-112319-kUg1Ec/manifests/10.19.142.117_provision_tempest.pp.log
Please check log file /var/tmp/packstack/20140814-112319-kUg1Ec/openstack-setup.log for more information


Expected results:


Additional info:
Within the openstack-setup.log:

tar --dereference -cpzf - apache ceilometer certmonger cinder concat firewall glance heat horizon inifile keystone memcached mongodb mysql neutron nova nssdb openstack packstack qpid rabbitmq rsync ssh stdlib swift sysctl tempest vcsrepo vlan vswitch xinetd | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@10.19.142.117 tar -C /var/tmp/packstack/e580af1b01594225bc4f3257542b0fed/modules -xpzf -
2014-08-14 11:38:33::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during Puppet run: 10.19.142.117_provision_tempest.pp
Error: concat(): Requires array to work with at /var/tmp/packstack/e580af1b01594225bc4f3257542b0fed/manifests/10.19.142.117_provision_tempest.pp:173 on node rl-controller.cloud.lab.eng.bos.redhat.com^[[0m
You will find full trace in log /var/tmp/packstack/20140814-112319-kUg1Ec/manifests/10.19.142.117_provision_tempest.pp.log

Comment 2 Gaël Chamoulaud 2014-09-02 09:24:34 UTC
Hi Roger,

Can you please tell me the version of openstack-packstack and openstack-puppet-modules used when you hit this ?

Comment 3 Gaël Chamoulaud 2014-09-02 14:07:04 UTC
Roger, 

I've tried to reproduce your issue for a two-nodes installation (1 Controller/1 COMPUTE on RHEL7 ) with the following components:

- packstack from git (Icehouse Branch) AND openstack-packstack-2014.1.1-0.40.dev1239.el7ost.noarch.rpm
- openstack-puppet-modules-2014.1-21.7.el7ost.noarch

And it works for me !

Could you please retry with the latest releases of packstack and OPM ?

Cheers,
Gaël.

Comment 4 rlopez 2014-09-03 19:27:33 UTC
The reason it didn't work is within the answers.cfg file I filled out the config_provision_tempest_user incorrectly thus causing the above issue. This can be closed.


Note You need to log in before you can comment on or make changes to this bug.