Bug 1130312 - 2.4.0 -> 2.4.1 Upgrade Docs Needed
Summary: 2.4.0 -> 2.4.1 Upgrade Docs Needed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: documentation
Version: Master
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 2.4.1
Assignee: Randy Barlow
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-14 20:14 UTC by Brian Bouterse
Modified: 2014-09-23 17:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 17:54:18 UTC


Attachments (Terms of Use)

Description Brian Bouterse 2014-08-14 20:14:55 UTC
A section needs to be added to the 2.4.1 release notes [0] explaining how to upgrade from 2.4.0.

[0]:  http://pulp-user-guide.readthedocs.org/en/master/release-notes/2.4.x.html

Comment 1 Randy Barlow 2014-08-22 20:28:06 UTC
https://github.com/pulp/pulp/pull/1126

Comment 2 Randy Barlow 2014-08-22 20:35:58 UTC
https://github.com/pulp/pulp_puppet/pull/132

Comment 3 Randy Barlow 2014-08-22 20:36:29 UTC
https://github.com/pulp/pulp_rpm/pull/553

Comment 4 Randy Barlow 2014-08-25 19:16:05 UTC
These PRs have all been merged. We don't have a readthedocs builder for our 2.4.1-dev branch, so QE will need to verify this by reading the docs directly from github. Here are links to the release notes for all three repos. Once we merge these to our release branch, readthedocs will be updated.

https://github.com/pulp/pulp/blob/2.4.1-dev/docs/sphinx/user-guide/release-notes/2.4.x.rst

https://github.com/pulp/pulp_puppet/blob/2.4.1-dev/docs/user-guide/release-notes/2.4.x.rst

https://github.com/pulp/pulp_rpm/blob/2.4.1-dev/docs/user-guide/release-notes/2.4.x.rst

Comment 6 Randy Barlow 2014-09-23 17:54:18 UTC
This is fixed in Pulp-2.4.1-1.


Note You need to log in before you can comment on or make changes to this bug.