Bug 1130363 - [Document] kdump behavior change
Summary: [Document] kdump behavior change
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Kernel_Crash_Dump_Guide
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: rc
: ---
Assignee: Petr Bokoc
QA Contact: ecs-bugs
URL:
Whiteboard:
: 1168445 (view as bug list)
Depends On:
Blocks: 1097761 1168400
TreeView+ depends on / blocked
 
Reported: 2014-08-15 03:16 UTC by Qiao Zhao
Modified: 2019-03-06 02:50 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-12 15:06:16 UTC


Attachments (Terms of Use)

Description Qiao Zhao 2014-08-15 03:16:50 UTC
Description of problem:
Since 7.1 (kexec-tools-2.0.7-1.el7), kdump behavior changed.
Previously, set kdump.conf option "path"
--
path /var/crash/test
--
('test' directory does not exist.)
start kdump service is ok.
But now, start kdump service will fail if 'test' directory does not exist.

Talk with developer, they said this is a correct change.
And this action is still different from RHEL6, so we need to illustrate this point in the RHEL7.1 document.

Version-Release number of selected component (if applicable):

k
How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Baoquan He 2014-08-25 10:31:26 UTC
In latest kdump of rhel7, in case no target is specified explicitly in /etc/kdump.conf, the behavior of path is changed, a check need be taken to see if any separate file system is mounted on any tier of 'path', and also to take the relevant action. Meanwhile different than that kdump need create the dir specified in "path" formerly if it does not exist, now change the behavior to be that ueser takes charge of the "path", make sure "path" has been created, especially when separate disk is mounted on this "path".

Comment 3 Vivek Goyal 2014-08-25 12:45:38 UTC
Hi Bao,

How about following. I think we want to talk about only directory creation behavior change at this point of time.

"In RHEL7, kdump expects directory where dump is being saved to be present otherwise kdump service will fail. This is different from RHEL6 behavior where directory will be automatically created if it is not present by kdump service."

Comment 4 Baoquan He 2014-08-25 15:00:32 UTC
Hi Vivek,

Yeah, it's fine. Your description is clear enough.  I had thought about giving more background knowledge.  It seems not necessary, and your description is clear enough.

Thanks
Baoquan

Comment 5 Baoquan He 2014-11-27 09:39:29 UTC
*** Bug 1168445 has been marked as a duplicate of this bug. ***

Comment 8 Dave Young 2015-01-20 08:21:06 UTC
Miroslav, do you know who is the qe contact for this bug, 7.1 rc is near, we should cover it in 7.1 doc...

Thanks
Dave


Note You need to log in before you can comment on or make changes to this bug.