Bug 1130380 - When compiling ffmpeg in centos 6.4 x64-bit compilation fails with Segmentation fault
Summary: When compiling ffmpeg in centos 6.4 x64-bit compilation fails with Segmentat...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 05:10 UTC by Robel Sharma
Modified: 2014-08-15 13:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 13:13:21 UTC


Attachments (Terms of Use)

Description Robel Sharma 2014-08-15 05:10:21 UTC
Description of problem: When building ffmpeg with libx264 the compiler crashed.

Trailing compilation trace is given. 

libavcodec/mlp_parser.c: In function ‘mlp_parse’:
libavcodec/mlp_parser.c:339: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
libavcodec/mlp_parser.c:339: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
libavcodec/mlp_parser.c:360: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
libavcodec/mlp_parser.c:360: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
libavcodec/mlp_parser.c:364: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
libavcodec/mlp_parser.c:365: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
CC	libavcodec/mlpdec.o
libavcodec/mlpdec.c: In function ‘read_restart_header’:
libavcodec/mlpdec.c:531: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
libavcodec/mlpdec.c:532: warning: ‘request_channels’ is deprecated (declared at libavcodec/avcodec.h:2010)
CC	libavcodec/mlpdsp.o
CC	libavcodec/mmvideo.o
CC	libavcodec/motion_est.o
libavcodec/motion_est.c: In function ‘h263_mv4_search’:
libavcodec/motion_est.c:573: warning: ‘P[4][1]’ may be used uninitialized in this function
libavcodec/motion_est.c:573: warning: ‘P[3][1]’ may be used uninitialized in this function
libavcodec/motion_est.c:573: warning: ‘P[2][1]’ may be used uninitialized in this function
libavcodec/motion_est.c: In function ‘interlaced_search.clone.2’:
libavcodec/motion_est.c:738: warning: ‘P[4][1]’ may be used uninitialized in this function
libavcodec/motion_est.c:738: warning: ‘P[3][1]’ may be used uninitialized in this function
libavcodec/motion_est.c:738: warning: ‘P[2][1]’ may be used uninitialized in this function
CC	libavcodec/motionpixels.o
CC	libavcodec/movsub_bsf.o
CC	libavcodec/movtextdec.o
CC	libavcodec/movtextenc.o
CC	libavcodec/mp3_header_decompress_bsf.o
CC	libavcodec/mpc.o
CC	libavcodec/mpc7.o
CC	libavcodec/mpc8.o
CC	libavcodec/mpeg12.o
CC	libavcodec/mpeg12data.o
CC	libavcodec/mpeg12dec.o
libavcodec/mpeg12dec.c: In function ‘setup_hwaccel_for_pixfmt’:
libavcodec/mpeg12dec.c:1245: warning: ‘xvmc_acceleration’ is deprecated (declared at libavcodec/avcodec.h:1741)
CC	libavcodec/mpeg12enc.o
CC	libavcodec/mpeg4audio.o
CC	libavcodec/mpeg4video.o
CC	libavcodec/mpeg4video_parser.o
CC	libavcodec/mpeg4videodec.o
CC	libavcodec/mpeg4videoenc.o
CC	libavcodec/mpegaudio.o
CC	libavcodec/mpegaudio_parser.o
CC	libavcodec/mpegaudiodata.o
CC	libavcodec/mpegaudiodec_fixed.o
CC	libavcodec/mpegaudiodec_float.o
In file included from libavcodec/mpegaudiodec_float.c:39:
libavcodec/mpegaudiodec_template.c: In function ‘mp_decode_layer3’:
libavcodec/mpegaudiodec_template.c:1294: internal compiler error: Segmentation fault



How reproducible:

The bug is not reproducible, so it is likely a hardware or OS problem.

Why to report?:

Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.

Comment 1 Jason McDonald 2014-08-15 05:16:54 UTC
This does not appear to be a bug in the Red Hat Bugzilla product.  Please file a new bug (or reopen this one) under the correct product and component.  From the above, I'm guessing that either Fedora or Red Hat Enterprise Linux would be an appropriate product.

Comment 2 Jakub Jelinek 2014-08-15 06:39:17 UTC
The bug is not reproducible, so it is likely a hardware or OS problem.
suggests that the gcc driver could not reproduce the problem when it retried.
So, the question is, are you able to reproduce this at all?  It could be just bad cooling in your box and CPU overheating or similar.

Comment 3 Robel Sharma 2014-08-15 08:48:50 UTC
Yes, I got it two times. After that it seems to be *OK* for now.

Comment 4 Jakub Jelinek 2014-08-15 09:05:35 UTC
Reproducible means always on the same file, with same command line options, same ICE.  If you retry and the file compiles fine, then just check your hw.

Comment 5 Robel Sharma 2014-08-15 13:07:48 UTC
Again got --

4322: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.

Comment 6 Jakub Jelinek 2014-08-15 13:13:21 UTC
If it was on a different file and the original worked, then just consider using different hardware.  gcc bugs are (almost always) reproduceable on the same input and same compiler options, you either always get the compiler failure, or never.


Note You need to log in before you can comment on or make changes to this bug.