Bug 1130409 - Met "Timed out waiting for http listening port for jboss process" when creating new jboss app on INT.
Summary: Met "Timed out waiting for http listening port for jboss process" when creati...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Mike McGrath
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 07:35 UTC by Liang Xia
Modified: 2015-05-15 00:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 00:50:38 UTC


Attachments (Terms of Use)

Description Liang Xia 2014-08-15 07:35:58 UTC
Description of problem:
When creating new jboss(as/eap/ews) app on INT, always met:
Starting jbossas cartridge
Timed out waiting for http listening port for jbossas process
Failed to execute: 'control start' for /var/lib/openshift/53ed75e603ef646ff1000707/jbossas

Can NOT reproduce this issue on devenv_5079

Version-Release number of selected component (if applicable):
INT(devenv_5079)

How reproducible:
always

Steps to Reproduce:
1.Create a new jboss(as/eap/ews) app on INT

Actual results:
$ rhc app create as jbossas-7 --no-git -s -g medium
Application Options
-------------------
Domain:     lxia
Cartridges: jbossas-7
Gear Size:  medium
Scaling:    yes
Creating application 'as' ... 
Starting jbossas cartridge
Timed out waiting for http listening port for jbossas process
Failed to execute: 'control start' for /var/lib/openshift/53ed75e603ef646ff1000707/jbossas

Expected results:
App created successfully.

Additional info:
aerogear-push-0.12.0 create from  https://cartreflect-claytondev.rhcloud.com/reflect?github=aerogear/openshift-origin-cartridge-aerogear-push failed with 他the same error on INT:
Starting aerogear-push cart
Timed out waiting for http listening port
Failed to execute: 'control start' for
/var/lib/openshift/53ed9fa36cec0eb98e000433/aerogear-push

Comment 1 Ben Parees 2014-08-15 14:11:19 UTC
Mike thinks a change me made introduced this, he's going to revert it.

Comment 2 Mike McGrath 2014-08-15 15:30:09 UTC
This should be fixed now and should be fixed permanently with: https://github.com/openshift/origin-server/pull/5716

Comment 3 Liang Xia 2014-08-18 10:24:46 UTC
QE will test once above pull request merged and deployed to INT.

Comment 4 Liang Xia 2014-08-19 02:54:11 UTC
Hi Rajat,

The pull request still in open status. Could you have a look?

Thanks,
Liang

Comment 5 Rajat Chopra 2014-08-19 03:00:42 UTC
More work needs to be done here. rhc-list-ports will fail and a workaround needs to be implemented still. The PR will stay open until then.

Comment 6 Xiaoli Tian 2014-08-20 01:31:18 UTC
Move it back to assigned since there is more fix needed, in case it's missing from bug triage.

Comment 8 Rajat Chopra 2014-08-20 02:42:15 UTC
Ben, can you point to the reverted fix, and document it here in the bug?
Otherwise yes, the permanent fix is what that PR is about.

Comment 9 Ben Parees 2014-08-20 03:01:35 UTC
As I understand it, Mike made the change directly in INT and then directly reverted it on INT, no bug/PR involved.

Comment 10 Liang Xia 2014-08-20 08:48:51 UTC
Move to verified since we do NOT met such errors in today's full function testing.


Note You need to log in before you can comment on or make changes to this bug.