Bug 1130477 - [JBossFuse]Can't create the second fuse app if the first fuse app is stopped
Summary: [JBossFuse]Can't create the second fuse app if the first fuse app is stopped
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Fuse
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Mikey Ariel
QA Contact: David Simansky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 10:43 UTC by xjia
Modified: 2015-07-20 00:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-07 02:12:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker ENTESB-1865 Critical Resolved Can't create the second fuse app if the first fuse app is stopped 2015-04-16 15:59:50 UTC

Description xjia 2014-08-15 10:43:41 UTC
Can't create the second fuse app if the first fuse app is stopped

H
H

Description of problem:
Create a fuse app and stop it. Then create the 2nd fuse app, it will fail. If start the 1st fuse app, the 2nd app can be created.

Version-Release number of selected component (if applicable):
openshift-origin-cartridge-fuse-6.1.0.redhat.389-1.el6op.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.rhc app create fuse fuse -e OPENSHIFT_FUSE_ZOOKEEPER_PASSWORD=redhat
2.rhc app stop fuse
3.rhc app create fuse2 fuse
4.rhc app start fuse
5.rhc app create fuse2 fuse

Actual results:
1. Success
2. Success
3. [root@broker ~]# rhc app create fuse2 fuse 
Using fuse-1.0.0 (JBoss Fuse 6.1.0 EA) for 'fuse'

Application Options
-------------------
Domain:     xuan
Cartridges: fuse-1.0.0
Gear Size:  default
Scaling:    no

Creating application 'fuse2' ... 
Unable to complete the requested operation due to: The server node.fuse.com that your application is running on failed to respond in time.  This may be due to a
system restart.
Reference ID: 0adb6cd1b08bdc59f1fb6bae285deda7
4. Success
5. [root@broker ~]# rhc app create fuse2 fuse 
Using fuse-1.0.0 (JBoss Fuse 6.1.0 EA) for 'fuse'

Application Options
-------------------
Domain:     xuan
Cartridges: fuse-1.0.0
Gear Size:  default
Scaling:    no

Creating application 'fuse2' ... Fuse cart already started
done

  Setting up fabric container
Using provided password from domain
Using provided url from domain

Fuse created successfully.  Please make note of these credentials:

   Console URL:        http://fuse2-xuan.fuse.com
   Console User:       admin
   Console Password:   redhat
   Zookeeper URL:      fuse-xuan.fuse.com:60501
   Zookeeper Password: redhat

   The Fuse Management Console will be available shortly at: http://fuse2-xuan.fuse.com

Fabric( 29806) is started successfully



Expected results:
2. Succeed to create fuse app.

Additional info:

Comment 2 Hiram Chirino 2014-08-21 13:24:24 UTC
The first fuse or amq app created in a domain will take on the roll of providing the ZooKeeper server for the fabric and OS domain.  The cluster will fail if the ZooKeeper server is not running in the domain.  Currently there is no way to make the ZooKeeper server HA inside of OS.

Comment 3 xjia 2014-09-01 07:36:29 UTC
Moved to Jira https://issues.jboss.org/browse/ENTESB-1865

Comment 4 JBoss JIRA Server 2014-09-09 10:28:09 UTC
Mikey Ariel <mariel@redhat.com> updated the status of jira ENTESB-1865 to Coding In Progress

Comment 5 JBoss JIRA Server 2014-09-26 13:18:35 UTC
Mikey Ariel <mariel@redhat.com> updated the status of jira ENTESB-1865 to Resolved

Comment 6 xjia 2015-01-07 02:12:55 UTC
According to jira ENTESB-1865, close this bug.


Note You need to log in before you can comment on or make changes to this bug.