Bug 1130486 - AR9271 very slow wireless connection
Summary: AR9271 very slow wireless connection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 11:19 UTC by rvcsaba
Modified: 2014-10-08 23:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-08 23:17:30 UTC


Attachments (Terms of Use)

Description rvcsaba 2014-08-15 11:19:28 UTC
Description of problem:

I upgrade Fedora 21 pre-alfa using yum. My TP-Link TL-WN722N USB wireless interface (0cf3:9271 Atheros Communications, Inc. AR9271 802.11n) very slow (30-100 kB/s down stream), but this interface work correctly in Fedora 20 (2-3 MB/s), 3.15.9-201 kernel.

The iwconfig command reported high invalid misc. packets:

          Link Quality=38/70  Signal level=-72 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:1592   Missed beacon:0

I tested with 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter, this interface faster (460 kB/s avarage), then TP-Linink in Fedora 21. The iwconfig reported few invalid misk. packet:

          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1818  Invalid misc:53   Missed beacon:0

This problem NetworkManager or kernel?

(Sorry my very bad english.)


Version-Release number of selected component (if applicable):

rpm -q NetworkManager kernel linux-firmware
NetworkManager-0.9.10.0-3.git20140704.fc21.x86_64
kernel-3.16.1-300.fc21.x86_64
linux-firmware-20140605-38.gita4f3bc03.fc21.1.noarch


How reproducible:

Download file.


Steps to Reproduce:
1.
2.
3.

Actual results:

slow wireless connection

Expected results:

fast wireless connection

Additional info:

Comment 1 rvcsaba 2014-08-16 09:03:38 UTC
I tested this bug with 3.15.10-200.fc20.x86_64 kernel, but Fedora 21 pre-alpha "release". My wireless network connection is fast (3.17 MB/s) with TL-WN722N.

This is a kernel regression, not NetworkManager problem.

Comment 2 rvcsaba 2014-09-06 11:14:03 UTC
kernel-3.16.2-300.fc21.x86_64: same problem

Comment 3 rvcsaba 2014-09-18 09:11:04 UTC
uname -r
3.16.3-300.fc21.x86_64

This problem actuality yet. Latest good kernel: kernel-3.15.10-201.fc20.x86_64

Comment 4 rvcsaba 2014-09-19 07:24:55 UTC
Rebuild kernel this patch?

https://bugzilla.kernel.org/show_bug.cgi?id=78581#c21

Comment 5 rvcsaba 2014-09-19 09:00:21 UTC
Workaround. I create /etc/modprobe.d/ath9k_htc.conf file:

options ath9k_htc nohwcrypt=1

Comment 6 phaux 2014-09-28 21:14:29 UTC
This adapter usually performs bad, but after upgrading to F21 I couldn't even connect to my router (it was stuck at sending DHCP packets)

(In reply to rvcsaba from comment #5)
> Workaround. I create /etc/modprobe.d/ath9k_htc.conf file:
> 
> options ath9k_htc nohwcrypt=1

This worked for me.

Comment 7 rvcsaba 2014-10-08 22:06:35 UTC
Latest kernel solved this problem. Thanks!

Comment 8 Josh Boyer 2014-10-08 23:17:30 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.