Bug 1130551 - hammer doesn't accept arbitrary order of arguments
Summary: hammer doesn't accept arbitrary order of arguments
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1128090
TreeView+ depends on / blocked
 
Reported: 2014-08-15 14:05 UTC by Pavel Studeník
Modified: 2017-01-13 20:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 20:04:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7123 None None None 2016-04-22 16:09:34 UTC
Red Hat Bugzilla 1128090 None None None Never

Internal Links: 1128090

Description Pavel Studeník 2014-08-15 14:05:24 UTC
Description of problem:
I try to use hammer and I don't know what is correct order of arguments.

for example: 

>> hammer -p changeme -u admin --csv content-host list --organization-id 1 
ID,Name
7097a1fc-713f-429c-bf99-6914a79243e4,cisco-c210-01.rhts.eng.bos.redhat.com

>> hammer --csv -p changeme -u admin content-host list --organization-id 1 
[Foreman] password for admin: 
(empty result)

>> hammer --password changeme -u admin content-host list --organization-id 1 --csv
Error: Unrecognised option '--csv'

See: 'hammer content-host list --help'

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_katello-0.0.4-10.el6sat.noarch
rubygem-hammer_cli-0.1.1-11.el6sat.noarch
rubygem-hammer_cli_foreman-0.1.1-15.el6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-3.el6sat.noarch

How reproducible:
always

Actual results:
Magic with ordering arguments

Expected results:
Accept arbitrary order of arguments

Comment 1 RHEL Product and Program Management 2014-08-15 14:23:19 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tomas Strachota 2014-08-18 08:17:55 UTC
Created redmine issue http://projects.theforeman.org/issues/7123 from this bug

Comment 4 Bryan Kearney 2015-08-25 18:00:13 UTC
Upstream bug component is Provisioning

Comment 5 Bryan Kearney 2016-07-08 20:42:58 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 7 Bryan Kearney 2017-01-13 20:04:01 UTC
This is an older bug which has been reported upstream. We are not going to track this bug downstream. When the upstream issue is resolved, the next build will contain the fix. Thank you.


Note You need to log in before you can comment on or make changes to this bug.