Bug 1130576 - 503 - Service Temporarily Unavailable
Summary: 503 - Service Temporarily Unavailable
Keywords:
Status: NEW
Alias: None
Product: Katello
Classification: Retired
Component: Installer
Version: Nightly
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-15 15:02 UTC by Tyler
Modified: 2014-08-18 18:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
/usr/share/katello/script/katello-debug (203.18 KB, application/x-gzip)
2014-08-15 15:02 UTC, Tyler
no flags Details

Description Tyler 2014-08-15 15:02:01 UTC
Created attachment 927139 [details]
/usr/share/katello/script/katello-debug

Description of problem:
After installation, https://host.domain.com/katello returns "503 Service Temporarily Unavailable".

Version-Release number of selected component (if applicable):
1.4

How reproducible:
Follow standard installation instructions

Steps to Reproduce:
1. https://fedorahosted.org/katello/wiki/Install
2.
3.

Actual results:
"503 Service Temporarily Unavailable".

Expected results:
Working instance of web page

Additional info:

Comment 1 Tyler 2014-08-18 18:00:00 UTC
It appears that the "thin" service isn't able to start, and therefore not listening on the default 5000/5001 ports, which is why the "503 Service Temporarily Unavailable" error is generated.   



/var/log/katello/thin-log.5000.log

[ERROR] There has been an error when creating the index -- elasticsearch returned:
400 : {"error":"IndexAlreadyExistsException[[katello_organization] Already exists]","status":400}

##

       from caused by: (PGError) ERROR:  relation "content_view_definition_bases" does not exist
LINE 4:              WHERE a.attrelid = '"content_view_definition_ba...

#######################

[root@katello.dev katello-configure-20140818-123129]# katello-service start
Starting Katello services...
Starting tomcat6:                                          [  OK  ]
Starting httpd:                                            [  OK  ]
Starting mongod:                                           [  OK  ]
Starting Qpid AMQP daemon:                                 [  OK  ]
Starting elasticsearch:                                    [  OK  ]
Please run katello-configure first
Starting katello:                                          [  OK  ]
Please run katello-configure first
Done.                                                      [FAILED]

######################

Both katello and katello-jobs fail to start.


Note You need to log in before you can comment on or make changes to this bug.