Bug 113063 - assertion error during update
assertion error during update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: 120092
  Show dependency treegraph
 
Reported: 2004-01-07 17:25 EST by Dave Jones
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 18:45:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2004-01-07 17:25:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Galeon/1.3.11

Description of problem:

(21:19:00:root@delerium:cambridge)# up2date -fu --nosig
 
Fetching package list for channel: fedora-core-1...
 
Fetching
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info...
########################################
 
Fetching package list for channel: updates-released...
 
Fetching
http://fedora.redhat.com/updates/released/fedora-core-1/headers/header.info...
########################################
 
Fetching package list for channel: updates-testing...
 
Fetching
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/1/i386/headers/header.info...
########################################
######################################
Fetching package list for channel: livna-stable...
 
Fetching
http://rpm.livna.org/fedora/1/i386/yum/stable/headers/header.info...
########################################
 
Fetching package list for channel: livna-testing...
 
Fetching
http://rpm.livna.org/fedora/1/i386/yum/testing/headers/header.info...
########################################
 
Fetching package list for channel: livna-unstable...
 
Fetching
http://rpm.livna.org/fedora/1/i386/yum/unstable/headers/header.info...
########################################
 
Fetching package list for channel: Nils...
 
Fetching
http://lisas.de/~nils/yum/fedora/1/i386/extras/headers/header.info...
########################################
 
Fetching Obsoletes list for channel: fedora-core-1...
 
Fetching Obsoletes list for channel: updates-released...
 
Fetching Obsoletes list for channel: updates-testing...
 
Fetching Obsoletes list for channel: livna-stable...
 
Fetching Obsoletes list for channel: livna-testing...
 
Fetching Obsoletes list for channel: livna-unstable...
 
Fetching Obsoletes list for channel: Nils...
 
Name                                    Version        Rel
----------------------------------------------------------
cpp                                     3.3.2          5             
     i386
gcc                                     3.3.2          5             
     i386
gcc-c++                                 3.3.2          5             
     i386
glibc                                   2.3.2          101.4         
     i686
glibc-common                            2.3.2          101.4         
     i386
glibc-devel                             2.3.2          101.4         
     i386
glibc-headers                           2.3.2          101.4         
     i386
kernel                                  2.4.22         1.2149.nptl   
     i686
kernel-smp                              2.4.22         1.2149.nptl   
     i686

kernel-source                           2.4.22         1.2149.nptl   
     i386
libgcc                                  3.3.2          5             
     i386
libgcj                                  3.3.2          5             
     i386
libstdc++                               3.3.2          5             
     i386
libstdc++-devel                         3.3.2          5             
     i386
nptl-devel                              2.3.2          101.4         
     i686
nscd                                    2.3.2          101.4         
     i386
 
 
Testing package set / solving RPM inter-dependencies...
########################################
cpp-3.3.2-5.i386.rpm:       ########################## Done.
gcc-3.3.2-5.i386.rpm:       ########################## Done.
gcc-c++-3.3.2-5.i386.rpm:   ########################## Done.
glibc-2.3.2-101.4.i686.rpm:  glibc-common-2.3.2-101.4.i3
glibc-devel-2.3.2-101.4.i38 ########################## Done.
glibc-headers-2.3.2-101.4.i
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1188, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 766, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1051, in batchRun
    batch.run()
  File "up2dateBatch.py", line 79, in run
  File "up2dateBatch.py", line 147, in __getPackages
  File "up2date.py", line 182, in getPackage
  File "rpcServer.py", line 110, in doCall
  File "repoDirector.py", line 35, in getPackage
  File "rpmSource.py", line 183, in getPackage
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
135, in getPackage
    agent = "Up2date 4.1/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
348, in fetchUrlAndWriteFD
    ret =  readFDBufWriteFD(fh, writefd, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
279, in readFDBufWriteFD
    chunk = fd.read(BUFFER_SIZE)
  File "/usr/lib/python2.2/httplib.py", line 1140, in read
    assert not self._line_consumed and self._line_left
AssertionError



Version-Release number of selected component (if applicable):
4.1.16

How reproducible:
Always

Steps to Reproduce:
1. up2date -fu --nosig
2.
3.
    

Actual Results:  see description

Additional info:
Comment 1 Dave Jones 2004-01-07 17:25:53 EST
after running it for a third time, it continued downloading the glibc
update (albeit slowly). Could it be timeout related ?
Comment 2 Dave Jones 2004-10-25 21:40:49 EDT
not seen this since fc1, feel free to close.

Note You need to log in before you can comment on or make changes to this bug.