Bug 1130727 - [abrt] dnf: copr.py:105:run:AttributeError: 'Cli' object has no attribute 'logger'
Summary: [abrt] dnf: copr.py:105:run:AttributeError: 'Cli' object has no attribute 'lo...
Keywords:
Status: CLOSED DUPLICATE of bug 1130559
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:1e7e349b1413c1a86fef209f436...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-17 04:35 UTC by Diogo Campos
Modified: 2014-08-17 10:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-17 10:09:21 UTC


Attachments (Terms of Use)
File: backtrace (1.10 KB, text/plain)
2014-08-17 04:35 UTC, Diogo Campos
no flags Details
File: environ (2.48 KB, text/plain)
2014-08-17 04:35 UTC, Diogo Campos
no flags Details

Description Diogo Campos 2014-08-17 04:35:33 UTC
Description of problem:
If I remember correctly, I tried to enable a COPR and this error appeared. Nevertheless, the COPR was enabled correctly.

Version-Release number of selected component:
dnf-0.6.0-1.fc21

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python -OO /usr/bin/dnf copr enable comzeradd/geary-git
dso_list:       dnf-plugins-core-0.1.2-1.fc21.noarch
executable:     /usr/bin/dnf
kernel:         3.16.1-300.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
copr.py:105:run:AttributeError: 'Cli' object has no attribute 'logger'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1072, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/copr.py", line 105, in run
    self.cli.logger.info(_("Repository successfully enabled."))
AttributeError: 'Cli' object has no attribute 'logger'

Local variables in innermost frame:
project_name: u'comzeradd/geary-git'
repo_filename: '/etc/yum.repos.d/_copr_comzeradd-geary-git.repo'
self: <dnf.plugin.dynamic.copr.CoprCommand object at 0x7f8911a61290>
subcommand: u'enable'
extcmds: [u'enable', u'comzeradd/geary-git']
chroot: 'fedora-21-x86_64'

Comment 1 Diogo Campos 2014-08-17 04:35:36 UTC
Created attachment 927405 [details]
File: backtrace

Comment 2 Diogo Campos 2014-08-17 04:35:38 UTC
Created attachment 927406 [details]
File: environ

Comment 3 Parag Nemade 2014-08-17 10:09:21 UTC

*** This bug has been marked as a duplicate of bug 1130559 ***


Note You need to log in before you can comment on or make changes to this bug.