Bug 1130738 - wrong case in firmware name
Summary: wrong case in firmware name
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-17 09:00 UTC by Kim Bisgaard
Modified: 2014-08-28 17:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-28 17:33:23 UTC


Attachments (Terms of Use)

Description Kim Bisgaard 2014-08-17 09:00:39 UTC
Description of problem:
The kernel tries to load radeon kaveri firmware with the name 'radeon/kaveri_*.bin' but the files are called 'radeon/KAVERI_*.bin' (uppercase)

Version-Release number of selected component (if applicable):
Kernel: 3.17.0-0.rc0.git4.2.fc22.x86_64
linux-firmware: 20140808-39.gitce64fa89.fc22.1.noarch

How reproducible:
Allways

/var/log/messages:
Aug 16 10:44:04 kim kernel: [    2.245283] ata_id (296) used greatest stack depth: 12088 bytes left
Aug 16 10:44:04 kim kernel: [    2.248384] [drm] radeon kernel modesetting enabled.
Aug 16 10:44:04 kim kernel: [    2.248500] fb: switching to radeondrmfb from VESA VGA
Aug 16 10:44:04 kim kernel: [    2.248605] Console: switching to colour dummy device 80x25
Aug 16 10:44:04 kim kernel: [    2.253102] [drm] initializing kernel modesetting (KAVERI 0x1002:0x1313 0x1043:0x85CB).
Aug 16 10:44:04 kim kernel: [    2.253163] [drm] register mmio base: 0xFEB00000
Aug 16 10:44:04 kim kernel: [    2.253165] [drm] register mmio size: 262144
Aug 16 10:44:04 kim kernel: [    2.253174] [drm] doorbell mmio base: 0xF0000000
Aug 16 10:44:04 kim kernel: [    2.253175] [drm] doorbell mmio size: 8388608
Aug 16 10:44:04 kim kernel: [    2.253286] ATOM BIOS: 113
Aug 16 10:44:04 kim kernel: [    2.253368] radeon 0000:00:01.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
Aug 16 10:44:04 kim kernel: [    2.253371] radeon 0000:00:01.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
Aug 16 10:44:04 kim kernel: [    2.253373] [drm] Detected VRAM RAM=1024M, BAR=256M
Aug 16 10:44:04 kim kernel: [    2.253374] [drm] RAM width 128bits DDR
Aug 16 10:44:04 kim kernel: [    2.254192] [TTM] Zone  kernel: Available graphics memory: 3529064 kiB
Aug 16 10:44:04 kim kernel: [    2.254194] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
Aug 16 10:44:04 kim kernel: [    2.254196] [TTM] Initializing pool allocator
Aug 16 10:44:04 kim kernel: [    2.254245] [TTM] Initializing DMA pool allocator
Aug 16 10:44:04 kim kernel: [    2.254888] [drm] radeon: 1024M of VRAM memory ready
Aug 16 10:44:04 kim kernel: [    2.254892] [drm] radeon: 1024M of GTT memory ready.
Aug 16 10:44:04 kim kernel: [    2.254988] [drm] Loading kaveri Microcode
Aug 16 10:44:04 kim kernel: [    2.255434] radeon 0000:00:01.0: Direct firmware load for radeon/kaveri_pfp.bin failed with error -2
Aug 16 10:44:04 kim kernel: [    2.255834] radeon 0000:00:01.0: Direct firmware load for radeon/kaveri_me.bin failed with error -2
Aug 16 10:44:04 kim kernel: [    2.256028] radeon 0000:00:01.0: Direct firmware load for radeon/kaveri_ce.bin failed with error -2
Aug 16 10:44:04 kim kernel: [    2.256219] radeon 0000:00:01.0: Direct firmware load for radeon/kaveri_mec.bin failed with error -2
Aug 16 10:44:04 kim kernel: [    2.256479] radeon 0000:00:01.0: Direct firmware load for radeon/kaveri_mec2.bin failed with error -2
Aug 16 10:44:04 kim kernel: [    2.256483] cik_cp: Failed to load firmware "radeon/kaveri_mec2.bin"
Aug 16 10:44:04 kim kernel: [    2.256521] [drm:cik_init] *ERROR* Failed to load firmware!
Aug 16 10:44:04 kim kernel: [    2.256526] radeon 0000:00:01.0: Fatal error during GPU init
Aug 16 10:44:04 kim kernel: [    2.256595] [drm] radeon: finishing device.
Aug 16 10:44:04 kim kernel: [    2.264360] [TTM] Finalizing pool allocator
Aug 16 10:44:04 kim kernel: [    2.264598] [TTM] Finalizing DMA pool allocator
Aug 16 10:44:04 kim kernel: [    2.265503] [TTM] Zone  kernel: Used memory at exit: 0 kiB
Aug 16 10:44:04 kim kernel: [    2.265850] [TTM] Zone   dma32: Used memory at exit: 0 kiB
Aug 16 10:44:04 kim kernel: [    2.265879] [drm] radeon: ttm finalized
Aug 16 10:44:04 kim kernel: [    2.270386] radeon: probe of 0000:00:01.0 failed with error -2


ls -1 /usr/lib/firmware/radeon/KAVERI*
/usr/lib/firmware/radeon/KAVERI_ce.bin
/usr/lib/firmware/radeon/KAVERI_me.bin
/usr/lib/firmware/radeon/KAVERI_mec.bin
/usr/lib/firmware/radeon/KAVERI_pfp.bin
/usr/lib/firmware/radeon/KAVERI_rlc.bin
/usr/lib/firmware/radeon/KAVERI_sdma.bin

Comment 1 Kim Bisgaard 2014-08-17 10:47:55 UTC
With kernel: 3.17.0-0.rc0.git6.1.fc22.x86_64

Tried to link firmware files to lower case names, and do a dracut update but got:
Aug 17 12:18:21 kim kernel: [    2.160315] [drm] Initialized drm 1.1.0 20060810                                                                                    │
Aug 17 12:18:21 kim kernel: [    2.187465] usb 3-2: new full-speed USB device number 3 using ohci-pci                                                              │
Aug 17 12:18:21 kim kernel: [    2.202091] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded                                                                         │
Aug 17 12:18:21 kim kernel: [    2.207241] r8169 0000:03:00.0 eth0: RTL8168g/8111g at 0xffffc90000c5e000, e0:3f:49:19:e1:f1, XID 0c000800 IRQ 35                   │
Aug 17 12:18:21 kim kernel: [    2.207245] r8169 0000:03:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]                                       │
Aug 17 12:18:21 kim kernel: [    2.230208] scsi host8: Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 7.0                                                       │
Aug 17 12:18:21 kim kernel: [    2.230208]         <Adaptec aic7850 SCSI adapter>                                                                                  │
Aug 17 12:18:21 kim kernel: [    2.230208]         aic7850: Single Channel A, SCSI Id=7, 3/253 SCBs                                                                │
Aug 17 12:18:21 kim kernel: [    2.230208]                                                                                                                         │
Aug 17 12:18:21 kim kernel: [    2.243503] ata_id (293) used greatest stack depth: 12016 bytes left                                                                │
Aug 17 12:18:21 kim kernel: [    2.258141] [drm] radeon kernel modesetting enabled.                                                                                │
Aug 17 12:18:21 kim kernel: [    2.258220] fb: switching to radeondrmfb from VESA VGA                                                                              │
Aug 17 12:18:21 kim kernel: [    2.258321] Console: switching to colour dummy device 80x25                                                                         │
Aug 17 12:18:21 kim kernel: [    2.262512] [drm] initializing kernel modesetting (KAVERI 0x1002:0x1313 0x1043:0x85CB).                                             │
Aug 17 12:18:21 kim kernel: [    2.262616] [drm] register mmio base: 0xFEB00000                                                                                    │
Aug 17 12:18:21 kim kernel: [    2.262618] [drm] register mmio size: 262144                                                                                        │
Aug 17 12:18:21 kim kernel: [    2.262626] [drm] doorbell mmio base: 0xF0000000                                                                                    │
Aug 17 12:18:21 kim kernel: [    2.262628] [drm] doorbell mmio size: 8388608                                                                                       │
Aug 17 12:18:21 kim kernel: [    2.262752] ATOM BIOS: 113                                                                                                          │
Aug 17 12:18:21 kim kernel: [    2.262839] radeon 0000:00:01.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)                                   │
Aug 17 12:18:21 kim kernel: [    2.262842] radeon 0000:00:01.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF                                                 │
Aug 17 12:18:21 kim kernel: [    2.262844] [drm] Detected VRAM RAM=1024M, BAR=256M                                                                                 │
Aug 17 12:18:21 kim kernel: [    2.262846] [drm] RAM width 128bits DDR                                                                                             │
Aug 17 12:18:21 kim kernel: [    2.264909] [TTM] Zone  kernel: Available graphics memory: 3529056 kiB                                                              │
Aug 17 12:18:21 kim kernel: [    2.264912] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB                                                              │
Aug 17 12:18:21 kim kernel: [    2.264914] [TTM] Initializing pool allocator                                                                                       │
Aug 17 12:18:21 kim kernel: [    2.264986] [TTM] Initializing DMA pool allocator                                                                                   │
Aug 17 12:18:21 kim kernel: [    2.265736] [drm] radeon: 1024M of VRAM memory ready                                                                                │
Aug 17 12:18:21 kim kernel: [    2.265741] [drm] radeon: 1024M of GTT memory ready.                                                                                │
Aug 17 12:18:21 kim kernel: [    2.265888] [drm] Loading kaveri Microcode                                                                                          │
Aug 17 12:18:21 kim kernel: [    2.266472] cik_fw: validation failed for firmware "radeon/kaveri_pfp.bin"                                                          │
Aug 17 12:18:21 kim kernel: [    2.266490] [drm:cik_init] *ERROR* Failed to load firmware!                                                                         │
Aug 17 12:18:21 kim kernel: [    2.266497] radeon 0000:00:01.0: Fatal error during GPU init                                                                        │
Aug 17 12:18:21 kim kernel: [    2.266556] [drm] radeon: finishing device.                                                                                         │
Aug 17 12:18:21 kim kernel: [    2.274303] [TTM] Finalizing pool allocator                                                                                         │
Aug 17 12:18:21 kim kernel: [    2.274545] [TTM] Finalizing DMA pool allocator                                                                                     │
Aug 17 12:18:21 kim kernel: [    2.275337] [TTM] Zone  kernel: Used memory at exit: 0 kiB                                                                          │
Aug 17 12:18:21 kim kernel: [    2.275376] [TTM] Zone   dma32: Used memory at exit: 0 kiB                                                                          │
Aug 17 12:18:21 kim kernel: [    2.275397] [drm] radeon: ttm finalized                                                                                             │
Aug 17 12:18:21 kim kernel: [    2.278416] radeon: probe of 0000:00:01.0 failed with error -22

Radeaon probably needs new firmware files :-(

Comment 2 Josh Boyer 2014-08-18 13:17:41 UTC
We have the newest firmware files available.

Dave, what do you want to do about the mismatched case?

Comment 3 Kim Bisgaard 2014-08-23 08:37:08 UTC
I was under the impression that the reason for pushing the development kernel out into rawhide was to get it tested? But it is difficult to test in this condition - I have the hw, but cannot use it because I miss the firmware - is there somewhere to download it from, until it is pushed as a linux-firmware rpm?

Comment 4 Dave Airlie 2014-08-28 03:25:33 UTC
the case isn't mismatched, the new firmwares were merged upstream today.

Comment 5 Josh Boyer 2014-08-28 12:57:20 UTC
(In reply to Dave Airlie from comment #4)
> the case isn't mismatched, the new firmwares were merged upstream today.

In which tree?

Comment 6 Josh Boyer 2014-08-28 17:33:23 UTC
Nevermind.  Kyle and I got it sorted out.

Should be available in tomorrow's rawhide.


Note You need to log in before you can comment on or make changes to this bug.