Bug 1130747 - Nova none HA flat, deployment stuck at 80% of compute hosts - clicking resume completed 100%
Summary: Nova none HA flat, deployment stuck at 80% of compute hosts - clicking resume...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
low
unspecified
Target Milestone: ---
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-17 10:18 UTC by Tzach Shefi
Modified: 2015-04-28 16:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-28 16:20:09 UTC


Attachments (Terms of Use)
Logs (53.98 KB, application/x-gzip)
2014-08-17 10:18 UTC, Tzach Shefi
no flags Details

Description Tzach Shefi 2014-08-17 10:18:44 UTC
Created attachment 927439 [details]
Logs

Description of problem: Strange my Nova none HA flat network, got stuck at 87%, 80% compute host. Looking around I decided to hit resume on staypuft GUI, deployment them completed 100% in a second. 

Can't explain why it got stuck, attached logs. 

Version-Release number of selected component (if applicable):
rhel-osp-installer-0.1.10-2.el6ost.noarch
foreman-installer-1.5.0-0.6.RC2.el6ost.noarch
openstack-foreman-installer-2.0.21-1.el6ost.noarch

How reproducible:
Not sure first time

Steps to Reproduce:
1. Deploy Nova none HA, Flat network + 2 compute nodes
2. Go to eat lunch :) 
3. Deployment stuck at 87%,  80% compute hosts. 
4. Had to hit resume button, to continue then it jumped to 100% completed.  


Actual results:
Had to hit refresh and resume to complete deployment. 

Expected results:
Should have completed by it self without needing a resume. 

Additional info:
Attached production log, and journalctl -xn from controller+computes.

Comment 2 Arthur Berezin 2015-04-28 16:20:09 UTC
Refocusing engineering efforts on OSP7-Manager. 
Closing this BZ due to low priority and no customer cases attached.


Note You need to log in before you can comment on or make changes to this bug.